Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Issue with all function names getting resolved
Issue with all function names getting resolved [message #1847752] Fri, 05 November 2021 13:41 Go to next message
badrinarayanan ranganathan is currently offline badrinarayanan ranganathanFriend
Messages: 3
Registered: November 2021
Junior Member
Hi,

I have imported existing code (C++) as a new project.
I see that many functions don't get resolved. Is there anything I would need to do to make this happen ?
The indexing has completed fully though.
Regards,
Badri.
Re: Issue with all function names getting resolved [message #1847759 is a reply to message #1847752] Sat, 06 November 2021 02:46 Go to previous messageGo to next message
David VavraFriend
Messages: 1430
Registered: October 2012
Senior Member
That could be a lot of things.
What functions aren't being resolved?
Yours? The system's?

What OS are you using?
What toolchain is being used?
Re: Issue with all function names getting resolved [message #1847762 is a reply to message #1847759] Sat, 06 November 2021 13:04 Go to previous messageGo to next message
badrinarayanan ranganathan is currently offline badrinarayanan ranganathanFriend
Messages: 3
Registered: November 2021
Junior Member
What functions aren't being resolved?
Yours? The system's?

My functions.

What OS are you using?
I am using Ubuntu 18.04

What toolchain is being used?
I am using the eclipse only for viewing the code and not for building it. I use aarch64 cross compiler for building from command line.

I therefore Create a New Project. C/C++, Makefile Project with Existing Code.
At the next stage where it prompts for "Toolchain for Indexer Settings", I select Cross GCC
Re: Issue with all function names getting resolved [message #1847763 is a reply to message #1847762] Sat, 06 November 2021 14:54 Go to previous messageGo to next message
David VavraFriend
Messages: 1430
Registered: October 2012
Senior Member
You have to tell Eclipse where your headers are.
The tool chain in a Makefile Project is only used to get builtins.
https://www.eclipse.org/community/eclipse_newsletter/2013/october/article4.php
Re: Issue with all function names getting resolved [message #1847772 is a reply to message #1847763] Sun, 07 November 2021 19:09 Go to previous message
badrinarayanan ranganathan is currently offline badrinarayanan ranganathanFriend
Messages: 3
Registered: November 2021
Junior Member
Thanks a lot David.

Regards,
Badri.
Previous Topic:Import NXP projects into Eclipse C/C++ 2020-03 IDE
Next Topic:Infineon XMC 4800: Eclipse not building libaries
Goto Forum:
  


Current Time: Mon Dec 05 15:51:06 GMT 2022

Powered by FUDForum. Page generated in 0.02068 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top