Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » A mysterious case of disappeared state in state machine diagram
A mysterious case of disappeared state in state machine diagram [message #1847677] Wed, 03 November 2021 13:13 Go to next message
Oleksandr Shashkevych is currently offline Oleksandr ShashkevychFriend
Messages: 2
Registered: November 2021
Junior Member
Hello all,

Since the official installation of Papyrus isn't working on macOS for me either, I've decided to install the minimal Eclipse Platform Runtime Binary from here and install the Papyrus plugin separately. That worked for me. So far so good.

Once I've started modeling a state machine I've faced an issue that initial states aren't displayed on my diagram. I can select and drag them around so they are simply not rendered for some reason.

index.php/fa/41252/0/

I was suspecting a platform rendering backend so I did install the same setup on my Ubuntu and I was surprised to see absolutely the same behavior. That was not rendering backend indeed so I switched back to macos.

I've tried quite everything in Papyrus itself (appearance and style options, css styles, etc) to fix this rendering issue but without success.

The next step was to give a try for pre-configured Eclipse for C++ IDE with additionally installed Papyrus. I was quite surprised to see my diagram without rendering issues.

index.php/fa/41253/0/

That was quite interesting and I started removing plugins from the Eclipse C++ IDE to see what is causing such behavior until I did find a culprit:

"Library Hover help for devhelp documentation"

After I uninstalled this plugin my diagram editor stopped showing Initial states. To ensure that this plugin is an actual culprit I reinstalled a minimal Eclipse Platform Runtime Binary, added the Papyrus with "Library Hover" plugin and Voila, my diagram got back initial states.

For me, the issue is resolved but I don't understand why Papyrus is depending on CDT plugin and according to plugin's description it's required "for creating hover help from installed C devhelp documentation."

Why Papyrus is depending on it? Any ideas?

[Updated on: Wed, 03 November 2021 14:31]

Report message to a moderator

Re: A mysterious case of disappeared state in state machine diagram [message #1847719 is a reply to message #1847677] Thu, 04 November 2021 13:15 Go to previous messageGo to next message
Ansgar Radermacher is currently offline Ansgar RadermacherFriend
Messages: 377
Registered: March 2011
Location: Paris Saclay, France
Senior Member
Hi,

the history and initial shape are SVG images. Thus, the error is related to a similar problem, we had in the Papyrus for Robotics RCP, see https://www.eclipse.org/forums/index.php/t/1108885/

Papyrus does not depend on a CDT plugin. But it seems that the CDT plugin depends on another graphics related plugin that is required to show SVG images, notably parsing their XML I also added additional dependencies to the Papyrus for Robotics RCP, but I realize now that the error needs to be corrected rather in Papyrus itself. Thanks for reporting it.

Ansgar
Re: A mysterious case of disappeared state in state machine diagram [message #1847751 is a reply to message #1847719] Fri, 05 November 2021 13:05 Go to previous message
Oleksandr Shashkevych is currently offline Oleksandr ShashkevychFriend
Messages: 2
Registered: November 2021
Junior Member
I also thought that issue probably isn't fixed directly by this CDT plugin and it could simply depend on some other plugins that actually fix rendering but after checking the list of installed plugins before and after I didn't spot any additional installed plugins except this "hover library".
Previous Topic:Does Papyrus support any Object Model or API? And using .uml files as XML files?
Next Topic:Problem setting up Development Environment for Papyrus
Goto Forum:
  


Current Time: Wed Sep 28 17:16:38 GMT 2022

Powered by FUDForum. Page generated in 0.02533 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top