Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Active provider in parameters file(Active provider)
Active provider in parameters file [message #1838147] Wed, 17 February 2021 13:04 Go to next message
Grégory G is currently offline Grégory GFriend
Messages: 2
Registered: February 2021
Junior Member
Hello,
I did not find a discussion on the subject.

Following the installation of eclipse on my virtual machine, I have an authentication request "Login Required / Please provide login details for ...".
By modifying the "Active Provider" parameter (Window / Preferences / Network connection) with the value "Direct", I no longer have the request.

The installation of eclipse must be generalized on multiple virtual machines and I would like the "Active Provider" parameter to be "Direct" without user intervention.
Could you tell me which configuration file I must set up or modify so that the "Active Provider" is informed with "Direct"?

I put the proxiesEnabled = false and systemProxiesEnabled = false parameters in the org.eclipse.core.net.prefs file but it didn't change anything.

Thanks for your help

*with Google translate*
Re: Active provider in parameters file [message #1838148 is a reply to message #1838147] Wed, 17 February 2021 14:11 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32016
Registered: July 2009
Senior Member
I believe these preferences (Window -> Preferences -> General -> Network Connections) are stored in eclipse/configuration/.settings/org.eclipse.core.net.prefs. If you entered this in the installer the installer copies those preferences to the installation.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Active provider in parameters file [message #1838616 is a reply to message #1838147] Tue, 02 March 2021 13:24 Go to previous message
Grégory G is currently offline Grégory GFriend
Messages: 2
Registered: February 2021
Junior Member
Hello and thank you for your answer.
I solved my problem.

The parameters were already in the eclipse configuration but were not taken into account when launching eclipse.
It turns out that the storage directory of the eclipse installation was in "Read Only" and this is what blocked the taking into account of the parameters. By putting the directory in "Read / Write" for the user, the problem was corrected.

Thanks for your help.
Previous Topic:Question about clang integration to Eclipse
Next Topic:Hello world will not work, Failed to init ct.sym
Goto Forum:
  


Current Time: Tue Sep 21 05:42:33 GMT 2021

Powered by FUDForum. Page generated in 0.03193 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top