Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Running Eclipse with JDK15 fails with exit code 1
Running Eclipse with JDK15 fails with exit code 1 [message #1837945] Thu, 11 February 2021 09:10
Jean Pierre Urkens is currently offline Jean Pierre UrkensFriend
Messages: 1
Registered: February 2021
Junior Member
After uppgrading my eclipse-jee-2020-06 installation it won't start .
Reason my default JAVA_HOME is set to JDK8 and it needs JDK11 or higher.
So I installed JDK15 and I am trying to start eclipse with following eclipse.ini settings:

-startup
plugins/org.eclipse.equinox.launcher_1.6.0.v20200915-1508.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.2.0.v20200915-1442
-product
org.eclipse.epp.package.jee.product
-showsplash
org.eclipse.epp.package.common
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vm
C:\Program Files\Java\jdk-15.0.1\bin\javaw.exe
-vmargs
-XX:+AggressiveOpts
-Dosgi.requiredJavaVersion=11
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-Dsun.java.command=Eclipse
-XX:+UseG1GC
-XX:+UseStringDeduplication
--add-modules=ALL-SYSTEM
-Dosgi.requiredJavaVersion=11
-Dosgi.dataAreaRequiresExplicitInit=true
-Xms1024m
-Xmx2048m
--add-modules=ALL-SYSTEM

It fails with exit code 1 (see attachment). Any idea why and how to fix this?
Previous Topic:Eclipse 4.18.0 Error starting process unknown reason
Next Topic:"The catalog could not be loaded..." when installing Eclipse
Goto Forum:
  


Current Time: Mon Sep 20 12:09:30 GMT 2021

Powered by FUDForum. Page generated in 0.03645 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top