Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Eclipse - problem with two runing php web applications from two different projects(Eclipse - problem with two runing php web applications from two different projects - each project is in a separate Eclipse instance - problem with interference?)
Eclipse - problem with two runing php web applications from two different projects [message #1837897] Tue, 09 February 2021 23:25
PHP Beginner is currently offline PHP BeginnerFriend
Messages: 1
Registered: February 2021
Junior Member
Eclipse - problem with two runing php web applications from two different projects - each project is in a separate Eclipse instance - problem with interference?

I have a problem with two runing php applications that are pleaced each one is in a separate
Eclipse project.

I run each of them from separata Eclipse instance but two Eclipse instances make interference
each other.

When I open my PHP project in an Eclipse IDE I start debug option and everything works normaly.

The first project is in directory
/home/<user>/eclipse-workspace/example5_com
The first project is at local apache virtual host domain
http://example5.com

The secound project is in directory
/home/<user>/eclipse-workspace/example5_com_n1
The secound project is at local apache virtual host domain
http://www.example5.com.n1

Both of these php projects are loaded in two separate Eclipe instances.

I use Eclipse in XUbuntu Linux.

Ubuntu 20.04.2 LTS \n \l

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04.2 LTS"

Java version is

openjdk 11.0.9.1 2020-11-04
OpenJDK Runtime Environment (build 11.0.9.1+1-Ubuntu-0ubuntu1.20.04)
OpenJDK 64-Bit Server VM (build 11.0.9.1+1-Ubuntu-0ubuntu1.20.04, mixed mode, sharing)

I installed Eclipse IDE for PHP developers
/home/<user>/eclipse/php-2020-12/eclipse/eclipse

I opened Eclipse IDE for php and I choosed

The first project from directory
/home/<user>/eclipse-workspace/example5_com
The first project is at local apache virtual host domain
http://example5.com

When I start debug the option everything works normaly
but the problem presists here when I try to start debuging in
another Eclipse instance project

The secound project is in directory
/home/<user>/eclipse-workspace/example5_com_n1
The secound project is at local apache virtual host domain
http://www.example5.com.n1

The two Eclipse applications start interferencing from secound loaded into first loaded instance
here are the screens of the problem I am trying to describe

1. I loaded Eclipse with the first project
/home/<user>/eclipse-workspace/example5_com

2. I choosed Rub/Debug in the first project and debug starts normaly

3. I loaded Eclipse with the secound project
/home/<user>/eclipse-workspace/example5_com_n1

4. I choosed Rub/Debug in the secound project and here the problem with interference
that starts happening

May somebody tell me what should be the problem?

Here are the screens in attachment.
  • Attachment: 1.png
    (Size: 184.23KB, Downloaded 25 times)
  • Attachment: 2.png
    (Size: 64.00KB, Downloaded 27 times)
  • Attachment: 3.png
    (Size: 140.38KB, Downloaded 24 times)
  • Attachment: 4.png
    (Size: 77.00KB, Downloaded 26 times)
Previous Topic:Generate Methods in PHP class
Next Topic:Font in JavaScript Editor in Eclipse PDT 2020-012 (4.18.0)
Goto Forum:
  


Current Time: Thu Sep 23 08:46:16 GMT 2021

Powered by FUDForum. Page generated in 0.01677 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top