Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » I don't know which "workspace" to choose (from make.bat to eclipse)
I don't know which "workspace" to choose (from make.bat to eclipse) [message #1836272] Sun, 27 December 2020 21:31 Go to next message
Capi La Learn is currently offline Capi La LearnFriend
Messages: 7
Registered: July 2020
Junior Member
Hello,

I found a java project that is working through a "make.bat" file with a command thing, and i would like to run it on ECLIPSE for java developers
the bat file says :
del *.class
cd calculPack
del *.class
cd ..
cd flashAutomInterpretor
del *.class
cd ..
del FlashAutom.jar
javac -target 1.8 -source 1.8 Main.java & :: i modified this one to fit my jdk version
jar cvmf MANIFEST.MF FlashAutom.jar *
java -jar FlashAutom.jar


Anyway i would like to open the project inside Eclipse and run it from there (the reason is there are things in eclipse that can create the uml diagram class from the project i think so i want to run it on eclipse)

I tried to use the workspace that leads to all the folders and files, yet eclipse would not reconize it.
I tried to choose a folder called .metadata, and same thing it did not work.
Here is a picture of what the folder looks like

https://i.postimg.cc/NGV0MhNb/screenshot-523.png

Is there any particular method to move from make.bat to an eclipse way to compile ?
Many thanks.

[Updated on: Sun, 27 December 2020 21:32]

Report message to a moderator

Re: I don't know which "workspace" to choose (from make.bat to eclipse) [message #1836277 is a reply to message #1836272] Mon, 28 December 2020 00:02 Go to previous message
Capi La Learn is currently offline Capi La LearnFriend
Messages: 7
Registered: July 2020
Junior Member
I tried my best and got this in the end :

Exception in thread "main" java.lang.NullPointerException
	at java.desktop/javax.swing.ImageIcon.<init>(ImageIcon.java:217)
	at BunnyEclipse/main.Aide$Fond.<init>(Aide.java:64)
	at BunnyEclipse/main.Aide.<init>(Aide.java:21)
	at BunnyEclipse/main.Periph.<init>(Periph.java:41)
	at BunnyEclipse/main.Main.main(Main.java:8)

Previous Topic:Eclipse Won't install
Next Topic:Can I use Eclipse IDE on a Ubuntu server?
Goto Forum:
  


Current Time: Tue Jun 22 15:28:45 GMT 2021

Powered by FUDForum. Page generated in 0.02636 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top