Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Mylyn » Updated to Eclipse 2020-12 Unable to resolve mylyn bundle
Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1836040] Fri, 18 December 2020 17:08 Go to next message
Marco Maccaferri is currently offline Marco MaccaferriFriend
Messages: 145
Registered: July 2009
Senior Member
Hello,

I have just updated my Eclipse installation from 2020-09 to 2020-12 and now it can't resolve mylyn bundles due to failed constraints:

!ENTRY org.eclipse.mylyn.commons.notifications.feed 4 0 2020-12-18 17:51:05.424
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.mylyn.commons.notifications.feed [607]
  Bundle was not resolved because of a uses constraint violation.
  org.apache.felix.resolver.reason.ReasonException: Uses constraint violation. Unable to resolve resource org.eclipse.mylyn.commons.notifications.feed [osgi.identity; type="osgi.bundle"; version:Version="1.17.2.v20200813-0821"; osgi.identity="org.eclipse.mylyn.commons.notifications.feed"; singleton:="true"] because it is exposed to package 'javax.xml.bind' from resources javax.xml.bind [osgi.identity; type="osgi.bundle"; version:Version="2.2.0.v201105210648"; osgi.identity="javax.xml.bind"] and jakarta.xml.bind [osgi.identity; type="osgi.bundle"; version:Version="2.3.3.v20201118-1818"; osgi.identity="jakarta.xml.bind"] via two dependency chains.

Chain 1:
  org.eclipse.mylyn.commons.notifications.feed [osgi.identity; type="osgi.bundle"; version:Version="1.17.2.v20200813-0821"; osgi.identity="org.eclipse.mylyn.commons.notifications.feed"; singleton:="true"]
    require: (&(osgi.wiring.bundle=javax.xml.bind)(bundle-version>=2.2.0))
     |
    provide: osgi.wiring.bundle: javax.xml.bind
  javax.xml.bind [osgi.identity; type="osgi.bundle"; version:Version="2.2.0.v201105210648"; osgi.identity="javax.xml.bind"]

Chain 2:
  org.eclipse.mylyn.commons.notifications.feed [osgi.identity; type="osgi.bundle"; version:Version="1.17.2.v20200813-0821"; osgi.identity="org.eclipse.mylyn.commons.notifications.feed"; singleton:="true"]
    require: (&(osgi.wiring.bundle=com.sun.xml.bind)(bundle-version>=2.2.0))
     |
    provide: osgi.wiring.bundle; bundle-version:Version="2.3.3.v20201118-1818"; osgi.wiring.bundle="com.sun.xml.bind"
  com.sun.xml.bind [osgi.identity; type="osgi.bundle"; version:Version="2.3.3.v20201118-1818"; osgi.identity="com.sun.xml.bind"]
    import: (&(osgi.wiring.package=javax.xml.bind)(&(version>=2.3.3)(!(version>=2.3.4))))
     |
    export: osgi.wiring.package: javax.xml.bind
  jakarta.xml.bind [osgi.identity; type="osgi.bundle"; version:Version="2.3.3.v20201118-1818"; osgi.identity="jakarta.xml.bind"]
	at org.eclipse.osgi.container.Module.start(Module.java:463)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1845)
	at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1838)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1779)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1743)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1665)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)


There are other erros messages in the log, but all seems similar, or a consequence of this.
Looks to me there is a conflict between packages. Is there a way to fix the installation ?

The OS is Windows 10, Java JDK 11.0.8.

Best regards,
Marco

[Updated on: Fri, 18 December 2020 17:08]

Report message to a moderator

Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1836063 is a reply to message #1836040] Sat, 19 December 2020 13:31 Go to previous messageGo to next message
Riccardo Nimser is currently offline Riccardo NimserFriend
Messages: 8
Registered: June 2015
Junior Member
I face the same issue. I spend the whole day yesterday, but I was not able to fix it so far. I think the issue is the missing bundle com.sun.xml.bind with version 2.2.0. However, I am not able to install it since version 2.3.3 is already there. I tried it with my custom Ooomph setup and via the Eclipse UI.

[Updated on: Sat, 19 December 2020 15:21]

Report message to a moderator

Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1836068 is a reply to message #1836063] Sat, 19 December 2020 15:43 Go to previous messageGo to next message
Riccardo Nimser is currently offline Riccardo NimserFriend
Messages: 8
Registered: June 2015
Junior Member
I finall managed to add com.sun.xml.bind with version 2.2.0 which solved the problem as expected.

[Updated on: Sat, 19 December 2020 16:00]

Report message to a moderator

Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1836069 is a reply to message #1836068] Sat, 19 December 2020 16:28 Go to previous messageGo to next message
Marco Maccaferri is currently offline Marco MaccaferriFriend
Messages: 145
Registered: July 2009
Senior Member
Riccardo Nimser wrote on Sat, 19 December 2020 10:43
I finall managed to add com.sun.xml.bind with version 2.2.0 which solved the problem as expected.


How ?

In the meantime I have opened a bug:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=569828
Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1836070 is a reply to message #1836069] Sat, 19 December 2020 16:57 Go to previous messageGo to next message
Riccardo Nimser is currently offline Riccardo NimserFriend
Messages: 8
Registered: June 2015
Junior Member
I misconfigured my custom Oomph setup first, but now I have version 2.2.0 and version 2.3.3 of the bundle com.sun.xml.bind installed properly. I used the Eclipse Orbit to pull in the version 2.2.0.
Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1836072 is a reply to message #1836070] Sat, 19 December 2020 17:10 Go to previous messageGo to next message
Marco Maccaferri is currently offline Marco MaccaferriFriend
Messages: 145
Registered: July 2009
Senior Member
Riccardo Nimser wrote on Sat, 19 December 2020 11:57
I misconfigured my custom Oomph setup first, but now I have version 2.2.0 and version 2.3.3 of the bundle com.sun.xml.bind installed properly. I used the Eclipse Orbit to pull in the version 2.2.0.


Ok, I more clear question: what you have done to fix the bundles ? What files have you edited ?

My upgraded installation has these:

18/12/2020  20:51           955.880 com.sun.xml.bind_2.2.0.v201505121915.jar
18/12/2020  17:40         1.206.296 com.sun.xml.bind_2.3.3.v20201118-1818.jar
18/12/2020  17:41           136.547 jakarta.xml.bind_2.3.3.v20201118-1818.jar
08/07/2020  13:51           124.948 javax.xml.bind_2.2.0.v201105210648.jar


And Mylyn is broken. What's the magic ?

Can't even revert the upgrade I have to reinstall the previous version!

[Updated on: Sat, 19 December 2020 17:10]

Report message to a moderator

Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1836073 is a reply to message #1836072] Sat, 19 December 2020 17:48 Go to previous messageGo to next message
Riccardo Nimser is currently offline Riccardo NimserFriend
Messages: 8
Registered: June 2015
Junior Member
I configured the version 2.2.0 not as greedy in my Oomph setup first, which was wrong. If you have both versions (2.2.0 and 2.3.3) listed as installed plugins then it should be fine.
  • Attachment: plugins.jpg
    (Size: 97.00KB, Downloaded 167 times)

[Updated on: Sat, 19 December 2020 20:48]

Report message to a moderator

Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1836155 is a reply to message #1836073] Tue, 22 December 2020 16:55 Go to previous messageGo to next message
Marco Maccaferri is currently offline Marco MaccaferriFriend
Messages: 145
Registered: July 2009
Senior Member
Riccardo Nimser wrote on Sat, 19 December 2020 12:48
I configured the version 2.2.0 not as greedy in my Oomph setup first, which was wrong. If you have both versions (2.2.0 and 2.3.3) listed as installed plugins then it should be fine.


Is there a reason why you don't want to write the details of what you have done ?

Anyway, I can't believe nobody cares about this bug, it is a showstopper, Mylyn is broken, can't work! Nobody noticed ?
Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1836295 is a reply to message #1836155] Mon, 28 December 2020 16:13 Go to previous messageGo to next message
Riccardo Nimser is currently offline Riccardo NimserFriend
Messages: 8
Registered: June 2015
Junior Member
I told you what I did. I use my own product catalog with Oomph and there I used the Eclipse Orbit to pull in the other version. Please tell me/us how you updated your Eclipse and if you have the 2 different versions listed as installed like in my screenshot.
Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1838918 is a reply to message #1836295] Tue, 09 March 2021 09:46 Go to previous messageGo to next message
Sascha Holzhauer is currently offline Sascha HolzhauerFriend
Messages: 3
Registered: October 2014
Junior Member
Installing Spring Dashboard (optional) from https://download.springsource.com/snapshot/TOOLS/nightly/e4.18 as workaround solved the issue for me (source: https://github.com/spring-projects/sts4/issues/588#issuecomment-762313076).
Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1841953 is a reply to message #1838918] Fri, 04 June 2021 08:12 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1798
Registered: July 2009
Location: Firenze, Italy
Senior Member
What I did is specifying this in my setup file

    <requirement
        name="com.sun.xml.bind"
        versionRange="[2.2.0,2.3.3)"/>
    <requirement
        name="com.sun.xml.bind"/>


Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1851093 is a reply to message #1841953] Mon, 28 March 2022 03:23 Go to previous messageGo to next message
Rhys Drummond is currently offline Rhys DrummondFriend
Messages: 3
Registered: June 2018
Location: Australia
Junior Member
I'm running STM32 Cube IDE 1.9.0 based on Eclipse 4.22.0.v20211124-1800... I've been fighting for hours on this and can't resolve this dependency.
https://community.st.com/s/question/0D53W00001CRRxKSAX/installing-mylyn-on-stm32cubeide?t=1648431506989
I have 2.2.0 and 2.3.3 of com.sun.sml.bind in the plugins folder and it's not happy. Remove 2.33 and some other feature stops working, of course.
Really, I'm hacking with stuff I'm just not familiar enough with yet.
Any help here would be appreciated. Thanks.
Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1851100 is a reply to message #1851093] Mon, 28 March 2022 06:50 Go to previous messageGo to next message
Lorenzo Bettini is currently offline Lorenzo BettiniFriend
Messages: 1798
Registered: July 2009
Location: Firenze, Italy
Senior Member
I guess that if the more recent version of com.sun.xml.bind is required by other features and the previous one is required by mylyn you don't have many choices: you could only ask again the mylyn developers to publish the fixed version...

Re: Updated to Eclipse 2020-12 Unable to resolve mylyn bundle [message #1854587 is a reply to message #1851100] Fri, 26 August 2022 16:25 Go to previous message
Hermann Vosseler is currently offline Hermann VosselerFriend
Messages: 10
Registered: July 2009
Junior Member
...and the real problem seems to be: there aren't any Mylyn developers left to care. Only Mylyn Wiki text was retained, the rest was removed from the Eclipse releases
Previous Topic:Mylyn broken with Eclipse 2202-06
Next Topic:Mylyn removed from Eclipse Releases since 2022-06
Goto Forum:
  


Current Time: Sun Nov 27 15:52:45 GMT 2022

Powered by FUDForum. Page generated in 0.04231 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top