Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012
RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012 [message #1836026] Fri, 18 December 2020 13:00 Go to next message
lea ilagan is currently offline lea ilaganFriend
Messages: 59
Registered: October 2012
Member
Hello,

Please advise. Is RCPTT 2.5.1 compatible with eclipse 202012?
I tried to use 202009 and i was able to start(launch) after updating AUT runtime to JRE 11.

However, it did not work in eclipse 202012.

Here's snippet of console.log, i attached the complete log.

OpenJDK 64-Bit Server VM warning: Ignoring option MaxPermSize; support was removed in 8.0
!SESSION 2020-12-18 07:52:59.953 -----------------------------------------------
eclipse.buildId=4.18.0.I20201202-1800
java.version=11.0.2
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.platform.ide -eclipse.keyring C:\Testing\RCPTT\IDE\ws-2.5.1-4\.metadata\.plugins\org.eclipse.pde.core\org.eclipse.platform.ide/secure_storage
Command-line arguments:  -product org.eclipse.platform.ide -data C:\Testing\RCPTT\IDE\ws-2.5.1-4/../aut-org.eclipse.platform.ide -dev file:C:/Testing/RCPTT/IDE/ws-2.5.1-4/.metadata/.plugins/org.eclipse.pde.core/org.eclipse.platform.ide/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog -eclipse.keyring C:\Testing\RCPTT\IDE\ws-2.5.1-4\.metadata\.plugins\org.eclipse.pde.core\org.eclipse.platform.ide/secure_storage

!ENTRY org.eclipse.emf.ant 4 0 2020-12-18 07:53:02.619
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.ant [100]
  Unresolved requirement: Require-Bundle: org.eclipse.emf.codegen.ecore; bundle-version="[2.9.0,3.0.0)"; resolution:="optional"
    -> Bundle-SymbolicName: org.eclipse.emf.codegen.ecore; bundle-version="2.9.1.v20140203-1126"; singleton:="true"
       org.eclipse.emf.codegen.ecore [102]
         Unresolved requirement: Require-Bundle: org.eclipse.jdt.core; bundle-version="[3.5.0,4.0.0)"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.codegen; bundle-version="[2.9.0,3.0.0)"
    -> Bundle-SymbolicName: org.eclipse.emf.codegen; bundle-version="2.9.0.v20140203-1126"; singleton:="true"
       org.eclipse.emf.codegen [101]
         Unresolved requirement: Require-Bundle: org.eclipse.jdt.core; bundle-version="[3.5.0,4.0.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:463)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1845)
	at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1838)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1779)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1743)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1665)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)
  • Attachment: console.log
    (Size: 72.08KB, Downloaded 86 times)
Re: RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012 [message #1836106 is a reply to message #1836026] Mon, 21 December 2020 12:33 Go to previous messageGo to next message
lea ilagan is currently offline lea ilaganFriend
Messages: 59
Registered: October 2012
Member
Hello Everyone,
Any inputs please...

Thanks,
Lea
Re: RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012 [message #1836690 is a reply to message #1836106] Tue, 12 January 2021 08:48 Go to previous messageGo to next message
lea ilagan is currently offline lea ilaganFriend
Messages: 59
Registered: October 2012
Member
Hello Everyone,

Badly needed. :(. Any inputs would be greatly appreciated.
I tried AUT "eclipse-platform-4.18-win32-x86_64.zip" to make sure the issue is not caused of our product and i got the same issue. :(

Please help.

Thank you so much in advance.
Lea
Re: RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012 [message #1836744 is a reply to message #1836690] Wed, 13 January 2021 09:41 Go to previous messageGo to next message
lea ilagan is currently offline lea ilaganFriend
Messages: 59
Registered: October 2012
Member
Hello,

We're able to start AUT after installing "Nebula" and "AspectsJ" from the Marketplace. There are still errors in the log, but at least we can now run rcptt.

Thanks,
Lea

[Updated on: Wed, 13 January 2021 09:41]

Report message to a moderator

Re: RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012 [message #1837267 is a reply to message #1836744] Tue, 26 January 2021 13:17 Go to previous messageGo to next message
Christian Strebel is currently offline Christian StrebelFriend
Messages: 2
Registered: January 2021
Junior Member
Hi

We have the same problem.
You just added AspectJ to your product under test. Or how did you do this exactly?
There are already some bugs reported. Would be really nice if they where addressed quickly.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=569862
https://bugs.eclipse.org/bugs/show_bug.cgi?id=569843

Thank you very much.
Re: RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012 [message #1837304 is a reply to message #1836026] Wed, 27 January 2021 10:00 Go to previous messageGo to next message
Michel van Westerlaak is currently offline Michel van WesterlaakFriend
Messages: 1
Registered: January 2021
Junior Member
Hello,

We also had the same issue, we added the jvm argument "-noverify".
This is a workaround until they fix the real issue.
Re: RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012 [message #1837325 is a reply to message #1837304] Wed, 27 January 2021 15:03 Go to previous messageGo to next message
Christian Strebel is currently offline Christian StrebelFriend
Messages: 2
Registered: January 2021
Junior Member
Hi

Thank you very much. This workaround works like a charm.
Just added the -noverify to our maven pom.xml like this:
        <groupId>org.eclipse.rcptt</groupId>
        <artifactId>rcptt-maven-plugin</artifactId>
        <version>2.5.2-SNAPSHOT</version>
        <extensions>true</extensions>
        <executions>
          <execution>
            <id>default-execute</id>
            <configuration>
              <aut>
                <vmArgs>
                  <vmArg>-noverify</vmArg>
                </vmArgs>
              </aut>
            </configuration>
          </execution>
        </executions>

Re: RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012 [message #1837965 is a reply to message #1837267] Thu, 11 February 2021 12:38 Go to previous messageGo to next message
lea ilagan is currently offline lea ilaganFriend
Messages: 59
Registered: October 2012
Member
Sorry for late reply..

Yes, we installed AspectsJ into AUT..

Thanks,
Lea
Re: RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012 [message #1840647 is a reply to message #1836026] Wed, 21 April 2021 10:31 Go to previous message
Martin Todorov is currently offline Martin TodorovFriend
Messages: 5
Registered: February 2020
Junior Member
we have an AUT based on 2020-03 and Java 11.
Application starts ok when outside of RCPTT.
RCPTT fails to start AUT with no log

"Process was terminated while waiting for AUT startup data"
index.php/fa/40375/0/

  • Attachment: 1.png
    (Size: 54.64KB, Downloaded 752 times)

[Updated on: Wed, 21 April 2021 10:32]

Report message to a moderator

Previous Topic:"Target platform initialization failed" error when trying to launch an SWT application in
Next Topic:Eclipse problems
Goto Forum:
  


Current Time: Sun Apr 21 11:50:23 GMT 2024

Powered by FUDForum. Page generated in 0.03745 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top