Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » exec-process function returns "error=2, No such file or directory"(Execution of exec-process from RCPTT)
exec-process function returns "error=2, No such file or directory" [message #1835359] Tue, 01 December 2020 15:15 Go to next message
Lee Gardner is currently offline Lee GardnerFriend
Messages: 4
Registered: October 2020
Junior Member
Hi all,

I am still quite new to RCPTT and while I have automated some of the functionality of my AUT I am having issues with running external scripts. Specifically bash scripts, which form ~30% of my automated script.

I have been attempting to use the exec-process function:

exec-process "\"//home//system//Scripts//Hello.sh\""

I have a script named Hello.sh which is located at:
/home/system/Scripts/

The script is executed without any issues when I run it manually. Btw, the script, the AUT and RCPTT are all run on a Linux environment.

Is it possible to use exec-process to execute scripts from the RCPTT 'Script' area? Or perhaps my syntax is wrong?

I get the below error message when attempting to execute:
Cannot run program ""//home//system//Scripts//Hello.sh"": error=2, No such file or directory.

Thank you,
Lee

[Updated on: Tue, 01 December 2020 15:17]

Report message to a moderator

Re: exec-process function returns "error=2, No such file or directory" [message #1835398 is a reply to message #1835359] Wed, 02 December 2020 12:49 Go to previous message
Lee Gardner is currently offline Lee GardnerFriend
Messages: 4
Registered: October 2020
Junior Member
Additional information:
From RCPTT I navigate to Run > External Tools > External Tools Configurations...

I have added my script here with the Location set to:
/mnt/home/system/Scripts/Hello.sh

When I click the Run button the word "Hello" is return in the RCPTT Console.

Can I run the same script directly from a Test Case using ECL code? It really isn't clear to me how this is supposed to work!
Previous Topic:Can't add text in a grid's cell
Next Topic:Containerized RCPTT test execution
Goto Forum:
  


Current Time: Mon Apr 15 18:53:11 GMT 2024

Powered by FUDForum. Page generated in 0.19613 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top