Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Launching Eclipse 2020-09R error Version 11 or greater is required.(Incompatible JVM Version 1.8.0_201 of the JVM is not suitable for this product. Version 11 or greater is required)
Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1833071] Thu, 01 October 2020 17:03 Go to next message
aaron mcphie is currently offline aaron mcphieFriend
Messages: 5
Registered: October 2020
Junior Member
Using the extraction from zip file and not the installer I get an error when launching the Eclipse software.
"Incompatible JVM Version 1.8.0_201 of the JVM is not suitable for this product. Version 11 or greater is required"
I've installed Java SE Development Kit 11 , 14, and 15 and continue to get the same error at launch. Each time I reboot and run java -version I see the version matches the last version installed:
Java version "15" 2020-09-15

Is there a config file that needs to be updated? Why does Eclipse not see the new version of java?
Re: Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1833080 is a reply to message #1833071] Thu, 01 October 2020 19:27 Go to previous messageGo to next message
Francesc Martinez is currently offline Francesc MartinezFriend
Messages: 1
Registered: October 2020
Junior Member
Hello

I have the same issue. The only thing that worked to me is to remove Eclipse manually and reinstall it, because in the first initialization after the installation it works. But when I close it, the next time I want to use it doesn't works.

I know this is an odd job and not a good solution. So, I hope if somebody more experienced can come and solve the problem in a "legit way".

If i find a good solution in other places I will come and post it, of course.
Re: Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1833082 is a reply to message #1833080] Thu, 01 October 2020 20:30 Go to previous messageGo to next message
aaron mcphie is currently offline aaron mcphieFriend
Messages: 5
Registered: October 2020
Junior Member
How do you uninstall it or install it? I've been using the zip file and extracting the Eclipse folder to C:\Program Files folder. In a cmd window I run java -version and it shows version 11 or whichever version I've installed. I have it band-aided for now by modifying the desktop shortcut to this:
"C:\Program Files\eclipse-2020-09R\eclipse.exe" -vm C:\progra~1\Java\jdk-11.0.8\bin\server\jvm.dll

But I'd like to figure out how to run it with out the switch.
Re: Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1833093 is a reply to message #1833082] Fri, 02 October 2020 07:47 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31903
Registered: July 2009
Senior Member
If you used the installer, it would know that Java 11 is needed and would try find it in your system registry, so even if Java 8 is the default on the system, but you have Java 11 installed, the installer would find it and use it. The installer generates an installation where the eclipse.ini includes two lines like this before the -vmargs line in that file:
-vm
C:\Program Files\Java\jdk-11.0.5\bin
You can edit the eclipse.ini file to add this manually (or, if it's already present with an older version of Java, to change it).


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1833115 is a reply to message #1833093] Fri, 02 October 2020 15:20 Go to previous messageGo to next message
aaron mcphie is currently offline aaron mcphieFriend
Messages: 5
Registered: October 2020
Junior Member
Can the installer be made silent? This is for a programming class and the software will be pushed through SCCM if I can this sorted.
I tried the suggestions found on https://wiki.eclipse.org/Eclipse.ini#-vm_value:_Windows_Example. Modifying the ini file as you described and was described in the wiki did not change anything. But modifying the shortcut does work.

Side note, even when I tried the installer the version of Java never changed from 1.8 (as reported in java -version).

[Updated on: Fri, 02 October 2020 15:21]

Report message to a moderator

Re: Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1833116 is a reply to message #1833115] Fri, 02 October 2020 15:21 Go to previous messageGo to next message
aaron mcphie is currently offline aaron mcphieFriend
Messages: 5
Registered: October 2020
Junior Member
No Message Body
Re: Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1833120 is a reply to message #1833116] Fri, 02 October 2020 18:23 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31903
Registered: July 2009
Senior Member
There is this bug open for a headless installer mode:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=487626

But everyone expects all software to be free and so no one is actually willing to fund anything.

Modifying the eclipse.ini most definitely works. The Eclipse Installer relies on this and I've done this a great many times to be able to assert that it most definitely work.

Using the Eclipse Installer won't change your default "java -version". When using the installer, you choose on the final page which Java version to use and if the version that you choose is not the default of the system, it will generate a -vm option in the eclipse.ini (and that definitely works because my system's default is Java 8 and yet I can create installations that use the Java 11 version also on my system).


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1833133 is a reply to message #1833120] Sat, 03 October 2020 07:45 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31903
Registered: July 2009
Senior Member
BTW, I imagine it would be pretty easy to make a mistake editing the eclipse.ini. Each argument must be on a separate line, i.e., there is no parsing to break arguments on spaces. So even a trailing space on a line is going to end up being part of the argument passed to the process. So be sure that the -vm is on a line all by itself, without trailing spaces, and that the subsequent separate line is the path to your Java installation. And make sure it's before the -vmargs line in the eclipse.ini.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1833250 is a reply to message #1833133] Wed, 07 October 2020 16:49 Go to previous messageGo to next message
aaron mcphie is currently offline aaron mcphieFriend
Messages: 5
Registered: October 2020
Junior Member
I stand (sit) corrected. I came into this knowing nothing and was being shown how to modify the file by a co-worker. We were trying to add the line at the bottom of the file. Once added above the -vmargs line it works fine. Thanks for the suggestion and hand holding.
Re: Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1835156 is a reply to message #1833071] Thu, 26 November 2020 00:59 Go to previous messageGo to next message
mohammed ali is currently offline mohammed aliFriend
Messages: 1
Registered: November 2020
Junior Member
Step 1: Installed the higher version of Java
Step 2: Navigate to bin folder of Java higher version
Step 3: Copy the path of Java bin folder as above step.
Step 4: In notepad, Open eclipse.ini from the eclipse folder (unzip)
Step 5: Add below text just above -vmargs,
-vm
path_of_Bin_folder\javaw.exe (e.g. C:\Program Files\Java\jdk-14.0.2\bin\javaw.exe)

Step 6: Save the notepad file

Step 7: Launch Eclipse 2020-09

Enjoy....!
Re: Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1841488 is a reply to message #1833093] Tue, 18 May 2021 21:29 Go to previous messageGo to next message
Jason Graf is currently offline Jason GrafFriend
Messages: 2
Registered: May 2021
Junior Member
I don't know if you will see this but thank you, this fixed my issue.
Re: Launching Eclipse 2020-09R error Version 11 or greater is required. [message #1841489 is a reply to message #1833120] Tue, 18 May 2021 21:32 Go to previous message
Jason Graf is currently offline Jason GrafFriend
Messages: 2
Registered: May 2021
Junior Member
IDE are supposed to be free... Not even Microsoft charges for their C family IDE, Visual Studios.
Previous Topic:Problem with open
Next Topic:Eclipse installation steps in Citrix for shared users (70+)
Goto Forum:
  


Current Time: Wed Jun 16 15:34:31 GMT 2021

Powered by FUDForum. Page generated in 0.02888 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top