Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Problem installing 2.23.0 on Eclipse 2020-06(Problem installing 2.23.0 on Eclipse 2020-06)
Problem installing 2.23.0 on Eclipse 2020-06 [message #1832139] Thu, 10 September 2020 01:23 Go to next message
Oleg Cohen is currently offline Oleg CohenFriend
Messages: 28
Registered: August 2016
Junior Member
Greetings,

I am trying to install 2.23.0 on a brand new Eclipse 2020-06 and I get the error below. I tried both the remote update site and the local archive. Same results.

Would appreciate any pointers!

Regards,
Oleg

An error occurred while collecting items to be installed
session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Artifact not found: osgi.bundle,org.eclipse.xtext.xbase.lib,2.23.0.v20200831-0723.
Artifact not found: osgi.bundle,org.eclipse.xtend.core,2.23.0.v20200831-0856.
Artifact not found: osgi.bundle,org.eclipse.xtend.doc,2.23.0.v20200831-0856.
Artifact not found: osgi.bundle,org.eclipse.xtend.examples,2.23.0.v20200831-0856.
Artifact not found: osgi.bundle,org.eclipse.xtend.ide,2.23.0.v20200831-0856.
Artifact not found: osgi.bundle,org.eclipse.xtend.ide.common,2.23.0.v20200831-0856.
Artifact not found: osgi.bundle,org.eclipse.xtend.lib,2.23.0.v20200831-0723.
Artifact not found: osgi.bundle,org.eclipse.xtend.lib.macro,2.23.0.v20200831-0723.
Artifact not found: osgi.bundle,org.eclipse.xtend.m2e,2.23.0.v20200831-0856.
Artifact not found: osgi.bundle,org.eclipse.xtend.standalone,2.23.0.v20200831-0856.
Artifact not found: osgi.bundle,org.eclipse.xtext,2.23.0.v20200831-0730.
Artifact not found: osgi.bundle,org.eclipse.xtext.activities,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.builder,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.builder.standalone,2.23.0.v20200831-0745.
Artifact not found: osgi.bundle,org.eclipse.xtext.buildship,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.common.types,2.23.0.v20200831-0745.
Artifact not found: osgi.bundle,org.eclipse.xtext.common.types.edit,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.common.types.shared,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.common.types.shared.jdt38,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.common.types.ui,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.doc,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.ecore,2.23.0.v20200831-0745.
Artifact not found: osgi.bundle,org.eclipse.xtext.generator,2.23.0.v20200831-0745.
Artifact not found: osgi.bundle,org.eclipse.xtext.ide,2.23.0.v20200831-0730.
Artifact not found: osgi.bundle,org.eclipse.xtext.java,2.23.0.v20200831-0745.
Artifact not found: osgi.bundle,org.eclipse.xtext.junit4,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.logging,1.2.15.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.m2e,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.purexbase,2.23.0.v20200831-0745.
Artifact not found: osgi.bundle,org.eclipse.xtext.purexbase.ide,2.23.0.v20200831-0745.
Artifact not found: osgi.bundle,org.eclipse.xtext.purexbase.ui,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.smap,2.23.0.v20200831-0745.
Artifact not found: osgi.bundle,org.eclipse.xtext.testing,2.23.0.v20200831-0730.
Artifact not found: osgi.bundle,org.eclipse.xtext.ui,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.ui.codemining,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.ui.codetemplates,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.ui.codetemplates.ide,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.ui.codetemplates.ui,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.ui.ecore,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.ui.shared,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.ui.testing,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.util,2.23.0.v20200831-0730.
Artifact not found: osgi.bundle,org.eclipse.xtext.xbase,2.23.0.v20200831-0745.
Artifact not found: osgi.bundle,org.eclipse.xtext.xbase.ide,2.23.0.v20200831-0745.
Artifact not found: osgi.bundle,org.eclipse.xtext.xbase.junit,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.xbase.testing,2.23.0.v20200831-0745.
Artifact not found: osgi.bundle,org.eclipse.xtext.xbase.ui,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.xbase.ui.testing,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.xtext.generator,2.23.0.v20200831-0730.
Artifact not found: osgi.bundle,org.eclipse.xtext.xtext.ide,2.23.0.v20200831-0730.
Artifact not found: osgi.bundle,org.eclipse.xtext.xtext.ui,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.xtext.ui.examples,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.xtext.ui.graph,2.23.0.v20200831-0808.
Artifact not found: osgi.bundle,org.eclipse.xtext.xtext.wizard,2.23.0.v20200831-0730.
Re: Problem installing 2.23.0 on Eclipse 2020-06 [message #1832146 is a reply to message #1832139] Thu, 10 September 2020 07:25 Go to previous messageGo to next message
Karsten Thoms is currently offline Karsten ThomsFriend
Messages: 740
Registered: July 2009
Location: Dortmund, Germany
Senior Member

You are using Eclipse 2020-06, where Xtext 2.22 was the target. Xtext 2.23 will be shipped with Eclipse 2020-09. Using the Xtext composite update site http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/ should work for you.
Re: Problem installing 2.23.0 on Eclipse 2020-06 [message #1832189 is a reply to message #1832146] Fri, 11 September 2020 08:45 Go to previous messageGo to next message
Oleg Cohen is currently offline Oleg CohenFriend
Messages: 28
Registered: August 2016
Junior Member
Thank you, I will wait for 2020-09 to try.
Re: Problem installing 2.23.0 on Eclipse 2020-06 [message #1832190 is a reply to message #1832189] Fri, 11 September 2020 08:47 Go to previous messageGo to next message
Karsten Thoms is currently offline Karsten ThomsFriend
Messages: 740
Registered: July 2009
Location: Dortmund, Germany
Senior Member

Release date of Eclipse 2020-09 is next week, Sep 16th.
Re: Problem installing 2.23.0 on Eclipse 2020-06 [message #1832194 is a reply to message #1832190] Fri, 11 September 2020 09:41 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13667
Registered: July 2009
Senior Member
it should also work with 2020-06.
and the error message make not sense when looking at update site or zip.

=> have no idea what you are/were exactly doing and if there is a general problem
just waiting for 2020-09 wont help


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:Problems with linking in Xtext unit testing with multiple DSLs
Next Topic:xtext-maven-plugin and DSL-Files located in src/main/resources
Goto Forum:
  


Current Time: Wed Dec 02 20:10:29 GMT 2020

Powered by FUDForum. Page generated in 0.03415 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top