Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse JustJ » Updating the installation's embedded JRE
Updating the installation's embedded JRE [message #1829664] Wed, 08 July 2020 12:07 Go to next message
Jan Poganski is currently offline Jan PoganskiFriend
Messages: 3
Registered: March 2011
Junior Member
First of all I would like to say "Thanks, Ed" for JustJ because it comes with good news which I found your recent blog post: "the ability to update the installation's embedded JRE as new ones are released."
(sorry I cannot share the link because links to external sites are not permitted for me as a first time forum user)

While offering a customized version of Eclipse I had no luck providing a new JRE via p2. I remember the discussion in this bug that has been marked with CLOSED WONTFIX after almost ten years:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=300812

That's why I am looking forward to following the instructions about "Building Products that Use JustJ JREs" at https://www.eclipse.org/justj/?page=documentation. (By the way, it includes a link to https://www.eclipse.org/forums/index.php/t/1104206 which seems to be unrelated.)

While studying the comments to your blog post I found some advice about " touch points to alter the eclipse.ini file to point to the appropriate target VM when installing/uninstalling the feature".

It feels like the information how to prepare for updating the installation's embedded JRE can only be found inside bug reports, forums or mailing lists. Can you recommend some place where to find most helpful instructions or even an example?

[Updated on: Mon, 13 July 2020 15:24]

Report message to a moderator

Re: Updating the installation's embedded JRE [message #1829670 is a reply to message #1829664] Wed, 08 July 2020 13:30 Go to previous messageGo to next message
Jan Poganski is currently offline Jan PoganskiFriend
Messages: 3
Registered: March 2011
Junior Member
This is the link to the mentioned blog post:
https://ed-merks.blogspot.com/2020/06/eclipse-justj.html
Re: Updating the installation's embedded JRE [message #1829676 is a reply to message #1829670] Wed, 08 July 2020 14:45 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31640
Registered: July 2009
Senior Member
Thanks for the comment on the broken link, apparently a trailing slash is needed to link to the correct thread. I've fixed it in the documentation.

This wiki page is useful for how to specify things like touchpoints in an installable unit:

https://wiki.eclipse.org/Equinox/p2/Customizing_Metadata#Touchpoint_Instruction_Advice:

You'll see a setjvm touchpoint in, for example, this p2.inf:

https://ci.eclipse.org/justj/job/build-jres/lastSuccessfulBuild/artifact/jre-gen/plugins/org.eclipse.justj.openjdk.hotspot.jre.full.win32.x86_64/META-INF/p2.inf/*view*/

Of course if you use the JustJ JREs, you don't need to do anything with regards to touchpoints. Those are present and are applied automatically.

Are you trying to follow the instructions but are stuck on some finer point?


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Updating the installation's embedded JRE [message #1829901 is a reply to message #1829676] Mon, 13 July 2020 15:24 Go to previous messageGo to next message
Jan Poganski is currently offline Jan PoganskiFriend
Messages: 3
Registered: March 2011
Junior Member
It sounds good that with the justj JREs I do not need to care about the touchpoints :-)
Before I can really try that I need to modernize my old Ant based build scripts (PDE build) or replace them with a Tycho based approach. Unfortunately the old scripts do not work anymore with the latest Eclipse version.
As the mentioned section of the justj documentation refers to Tycho I assume this is the way to go.
Re: Updating the installation's embedded JRE [message #1829906 is a reply to message #1829901] Mon, 13 July 2020 17:00 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31640
Registered: July 2009
Senior Member
Definitely Maven in combination with Tycho is the way to do modern builds. I had to convert EMF's build from Buckminster to Tycho, which I kind of resented, but it was well worth it in the end and for the long term...

I do consulting if you need professional help. :-P


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:JustJ requires org.eclipse.equinox.p2.iu?
Next Topic: javax.activation and javax.xml.bind ??
Goto Forum:
  


Current Time: Fri Dec 04 14:57:39 GMT 2020

Powered by FUDForum. Page generated in 0.02233 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top