Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » Problem with graphiti 0.11.4 dependency
Problem with graphiti 0.11.4 dependency [message #1827839] Mon, 25 May 2020 10:19 Go to next message
Jose Gisbert is currently offline Jose GisbertFriend
Messages: 3
Registered: May 2020
Junior Member
Greetings graphiti community,

I take part in the development of a project which requires graphiti 0.11.4. Until recently I grabbed graphiti from the software site at the graphiti archive, but now I am getting an error message at the target definition telling that the artifacts cannot be found.

I tried with the zip file listed next to the software site URL at the graphiti download page, but I get the same result.

Looking to the zip contents and comparing to more recent versions (from version 0.14.0), I observed that version 0.11.4 misses a .jar file for every artifact. ┬┐Maybe the upload site is broken?

I have attached some captures of what I have described to this post.

Sorry if this is not the appropriate place to discuss this issue, but I hope you can help me to solve it.

Thank you in advance.
Re: Problem with graphiti 0.11.4 dependency [message #1827904 is a reply to message #1827839] Tue, 26 May 2020 15:46 Go to previous messageGo to next message
Michael Wenz is currently offline Michael WenzFriend
Messages: 1926
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Hi Jose,

I just tried to install 0.11.4 into a fresh Eclipse on my laptop and used the update site https://archive.eclipse.org/graphiti/updates/0.11.4/ for that. I worked for me without errors, there are no missing JARs. Maybe that was a temporary issue, so could you just retry?

Also I'm not aware of any recent changes to that repository. Just as a side note, that Graphiti version is now almost 6 Years old. Have you thought about upgrading the a newer version?

Michael
Re: Problem with graphiti 0.11.4 dependency [message #1828241 is a reply to message #1827904] Thu, 04 June 2020 16:07 Go to previous messageGo to next message
Jose Gisbert is currently offline Jose GisbertFriend
Messages: 3
Registered: May 2020
Junior Member
Hi Michael,

Thank you for your fast response and sorry for the delay. I have tried again a minute ago. This is what I have done:

1. download a fresh copy of Eclipse for Eclipse commiters
2. start Eclipse, pick a non existing directory as workspace
3. add a new Target Platform with nothing
4. add Luna software site (http://download.eclipse.org/releases/luna/) and Eclipse Scout and GEF SDK
5. add Graphiti 0.11.4 update site (http://archive.eclipse.org/graphiti/updates/0.11.4) and Graphiti

I get the same "Artifact not found" error message. If I replace Graphiti update site with the downloadable zip, the results are the same.

That version of Graphiti is a dependency for a third party plug-in that we use at our project and that is not longer actively mantained. We prefer not to modify the third party plug-in, though. So, that's the reason why we need Graphiti 0.11.4.

I realised that I cannot get Graphiti artifacts from the archive update site because I lost my workspace not long ago and I had to configure the project development environment again.

Thank you once more.

Jose
Re: Problem with graphiti 0.11.4 dependency [message #1828242 is a reply to message #1828241] Thu, 04 June 2020 16:13 Go to previous message
Jose Gisbert is currently offline Jose GisbertFriend
Messages: 3
Registered: May 2020
Junior Member
Hi again Michael,

I tried with version 0.11.2 from Luna software site and it is working. Graphiti 0.11.4 from Graphiti software site is still failing, but, I gess we can use 0.11.2 as a workaround.

Thank you very much for your time.

Greetings,

Jose
Previous Topic:Diagram stores all pictogramLinks - simplify xml
Next Topic:SVG export fails with NPE
Goto Forum:
  


Current Time: Sat May 08 20:17:18 GMT 2021

Powered by FUDForum. Page generated in 0.02510 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top