Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » Backward compatibility between 4DIAC IDE and forte(Using latest 4DIAC IDE with older forte versions)
Backward compatibility between 4DIAC IDE and forte [message #1827386] Thu, 14 May 2020 02:36 Go to next message
NOJA Power is currently offline NOJA PowerFriend
Messages: 19
Registered: May 2020
Junior Member
Hi,

I'm wondering if the latest 4DIAC IDE is intended to be backward compatible with older versions of forte?

For example, I have the latest 4DIAC IDE (version 1.12.1) and an older forte (version 1.8.4).

When I deploy a simple application, I get the following error in 4DIAC IDE Deployment Console but the application is running in forte. I can switch to the 4DIAC IDE Debug Perspective and add Watch to see the application running.
<Request Action="QUERY" ID="0">
<FB Name="*" Type="*"/>
</Request>

<Response ID="0" Reason="UNSUPPORTED_CMD"/>

Can the latest 4DIAC IDE be used with older versions of forte? If so, are there any limitation, issues or features in the 4DIAC IDE that are not backward compatible with older versions of forte?
Re: Backward compatibility between 4DIAC IDE and forte [message #1827433 is a reply to message #1827386] Thu, 14 May 2020 12:00 Go to previous message
Alois Zoitl is currently online Alois ZoitlFriend
Messages: 1067
Registered: January 2014
Senior Member
Hi,

in general we try to be backwards compatible. The reason for this error message is that with one of the previous versions (I think it was 1.10.0) we introduced a great improvement to the download process: we check which resources are currently running in a device and allow users to overwrite existing resources or abort it.

However in order that this features is working we need the query feature enabled. This was per default deactivated in pre 1.10.0 4diac FORTE versions. So be enabling QUERY in your CMake configuration this error message should go away.

If this is not possible for some reasons you can also ignore it. It will not affect the download process in your case.

As you are a long term and heavy user it may makes sense that we schedule a web-meeting to exchange on your current needs and also that we can show what we have on the road-map for Eclipse 4diac. Because I think many of the things we are planning are interesting for you but may effect how you work.
Previous Topic:Problem with updating 4DIAC to the latest release
Next Topic:F_UDINT_TO_USINT function block in forte
Goto Forum:
  


Current Time: Thu Nov 26 12:36:42 GMT 2020

Powered by FUDForum. Page generated in 0.02126 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top