Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Acceleo] Remove trailing white spaces in generated Java wrapper
[Acceleo] Remove trailing white spaces in generated Java wrapper [message #1827277] Tue, 12 May 2020 06:49 Go to next message
Denis Nikiforov is currently offline Denis NikiforovFriend
Messages: 252
Registered: August 2013
Senior Member
Hi

Acceleo generates a Java wrapper for each template. (I mean the wrapper derived from AbstractAcceleoGenerator class)

Each time I modify the Acceleo template, the Java file is updated and the following white spaces are added:
index.php/fa/38092/0/

When I change something in the Java wrapper itself manually, Eclipse auto removes these white spaces.

Is it possible to configure Acceleo so it will auto-remove these spaces, when the wrapper is regenerated?

The following option seems to have no effect: Windows -> Preferences -> Java -> Code Style -> Clean Up -> Remove trailing whitespace -> All lines
Re: [Acceleo] Remove trailing white spaces in generated Java wrapper [message #1827282 is a reply to message #1827277] Tue, 12 May 2020 08:59 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6755
Registered: July 2009
Senior Member
Hi

I suspect you need to tweak Windows -> Preferences -> Java -> Editor -> Save Actions

Regards

Ed Willink
Re: [Acceleo] Remove trailing white spaces in generated Java wrapper [message #1827303 is a reply to message #1827282] Tue, 12 May 2020 16:30 Go to previous messageGo to next message
Denis Nikiforov is currently offline Denis NikiforovFriend
Messages: 252
Registered: August 2013
Senior Member
It seems that this option has no effect on a generated Java code. Save actions are executed only when I edit the file manually.
Re: [Acceleo] Remove trailing white spaces in generated Java wrapper [message #1827305 is a reply to message #1827303] Tue, 12 May 2020 17:41 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6755
Registered: July 2009
Senior Member
HI

In that case it may be an Acceleo bug. IIRC EMF's GenModel has an apply formatting option that I've never found useful, because I run from an MWE2 script that has no JDT to animate.

Regards

Ed Willink
Previous Topic:Getting NullPointerException while running JET Transformation Project in Eclipse
Next Topic:Increment of Int in while loop?
Goto Forum:
  


Current Time: Thu Jul 02 22:32:35 GMT 2020

Powered by FUDForum. Page generated in 0.02163 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top