Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Missing dependency while product export
Missing dependency while product export [message #1824408] Tue, 14 April 2020 23:31
Kunal Harkare is currently offline Kunal HarkareFriend
Messages: 2
Registered: November 2017
Junior Member
I created an RCP Plug-in project using template "Eclipse 4 RCP Application" (Plugin A)
I then created another Plugin-in project to contribute to Plugin A(Plugin B)

In the MANIFEST.MF file of Plugin A, I added Plugin B in the list of "Required Plug-ins"
under "Dependencies" tab, since Plugin A uses some classes defined in Plugin B.

When I try to run my product file, which is in Plugin A, it runs without any errors but when I try to export my product file using "Eclipse export wizard", it fails with below error
"A problem occured while invoking the director"

When I logged the error to a log file it showed below message
Missing requirement: Plugin A requires 'osgi.bundle; Plugin B' but it could not be found.

Eclipse is not able to find Plugin B. Am I missing something here? Are there any more configuration required?
Previous Topic:Is it possible to auto-install plugin dependencies?
Next Topic:DS Annotations missing from permanent build path
Goto Forum:
  


Current Time: Mon Aug 03 19:21:11 GMT 2020

Powered by FUDForum. Page generated in 0.01348 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top