Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » JavaFx install error(error during javaFx install from Eclipse Marketplace)
JavaFx install error [message #1821999] Tue, 25 February 2020 14:26 Go to next message
Victor Koopman is currently offline Victor KoopmanFriend
Messages: 1
Registered: February 2020
Junior Member
When I try to install JavaFx from the Eclipse marketplace I get an error. It says it can't install because it needs JDT UI Tooling for JavaFx to complete the install. This is weird because JDT UI Tooling for JavaFx is part of JavaFx. How is it possible to need part of the software you're trying to install to complete the install? The full error message is below.

Cannot complete the install because one or more required items could not be found.
Software currently installed: e(fx)clipse - IDE 3.5.0.201907240300 (org.eclipse.fx.ide.feature.feature.group 3.5.0.201907240300)
Missing requirement: JDT UI Tooling for JavaFX 3.5.0.201907240300 (org.eclipse.fx.ide.jdt.ui 3.5.0.201907240300) requires 'osgi.bundle; org.eclipse.emf.databinding.edit 1.2.0' but it could not be found
Cannot satisfy dependency:
From: e(fx)clipse - IDE - Basic 3.5.0.201907240300 (org.eclipse.fx.ide.basic.feature.feature.group 3.5.0.201907240300)
To: org.eclipse.equinox.p2.iu; org.eclipse.fx.ide.jdt.ui [3.5.0.201907240300,3.5.0.201907240300]
Cannot satisfy dependency:
From: e(fx)clipse - IDE 3.5.0.201907240300 (org.eclipse.fx.ide.feature.feature.group 3.5.0.201907240300)
To: org.eclipse.equinox.p2.iu; org.eclipse.fx.ide.basic.feature.feature.group [3.5.0.201907240300,3.5.0.201907240300]
Re: JavaFx install error [message #1822014 is a reply to message #1821999] Tue, 25 February 2020 17:58 Go to previous messageGo to next message
Eitan Rosenberg is currently offline Eitan RosenbergFriend
Messages: 63
Registered: October 2018
Member
Hi,

I do not use this plugin (but I got curious...).()

I just install e(fx)clipse - IDE 3.5.0.201907240300 into a fresh install of eclipse with no problem.

I am using

windows 10.

Eclipse: 2019-12 (4.14.0)

Java: openjdk-13.0.1_windows-x64
Re: JavaFx install error [message #1822059 is a reply to message #1822014] Wed, 26 February 2020 13:05 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31639
Registered: July 2009
Senior Member
Did you enable Contact all update sites... in the dialog. It seems it can't find org.eclipse.emf.databinding.edit version 1.2.0, but that's a pretty old version and should be available in one of the repositories automatically in your list.

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Maven not working with proxy in Eclipse
Next Topic:Serial port
Goto Forum:
  


Current Time: Thu Dec 03 21:11:26 GMT 2020

Powered by FUDForum. Page generated in 0.02133 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top