Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Acceleo] Order of TemplateParameterSubstitution in TemplateBindings
[Acceleo] Order of TemplateParameterSubstitution in TemplateBindings [message #1821445] Thu, 13 February 2020 08:32
Michael Nestler is currently offline Michael NestlerFriend
Messages: 30
Registered: September 2014
Member
Hello,
I have a problem with the correct order of TemplateSubstitutionParameters in TemplateBindings.
In attachment template.test.acceleo.cpp/generated/TemplateBindings.h I always get
"typedef TemplateClass <Tp21, Tp1> TemplateUser1;"
According the definition in attachment template.test/template.test.uml I expect
"typedef TemplateClass <Tp1, Tp21> TemplateUser1;"

In template.test.uml I checked the TemplateBinding below
<packagedElement xmi:type="uml:DataType" xmi:id="_pBDKYEwGEeqmdM0IbrOGXg" name="TemplateUser1">
for me the order of the substitution parameter is ok.
Enclosed 2 attachments (model, Acceleo project) to reproduce the behavior.
Kind regards
Michael

[Updated on: Thu, 13 February 2020 13:47]

Report message to a moderator

Previous Topic:Acceleo source generator always replaces target file
Next Topic:[Acceleo] Suppress some warnings
Goto Forum:
  


Current Time: Tue Oct 20 07:15:51 GMT 2020

Powered by FUDForum. Page generated in 0.02039 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top