Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Kura » [Beginner] getting 14,000+ errors trying to setup developer workspace(Tried both Oomph and java + workspace archive)
[Beginner] getting 14,000+ errors trying to setup developer workspace [message #1819619] Sat, 18 January 2020 15:17 Go to next message
D Southwick is currently offline D SouthwickFriend
Messages: 3
Registered: January 2020
Junior Member

Apologies if this if this is already answered, want unable to find anything in search.

I'm trying kura for the first time, and have been struggling to follow the Hello World tutorial. Trying to setup the latest eclipse (2019-12) with Oomph results in many projects that cannot compile, and 14,000+ errors.

I tried using neon + the workspace archive, however this results in Unhandled loop exception, Server 'org.eclipse.epp.logging.aeri.ide.server' failed, and finally an un-launchable neon install.

I went back to the most recent eclipse and tried again (at least it doesn't flat-out brick itself with kura...) and attempted the first steps of the Hello World tutorial - only to find that the dependency management packages (MANIFEST.MF) are locked to org.eclipse.kura.* - no way to import slf4j or osgi.

Is this just an outdated tutorial? what is the magic combination of eclipse setup to get something that doesn't flat-out crash or need 14,000 error debugging steps to be able to follow the beginner tutorial?

using openjdk-1.8.0_232, rhel8
Re: [Beginner] getting 14,000+ errors trying to setup developer workspace [message #1819688 is a reply to message #1819619] Tue, 21 January 2020 13:12 Go to previous message
Alessandro Bianchin is currently offline Alessandro BianchinFriend
Messages: 1
Registered: January 2020
Junior Member
have you tried to switch target platform? If not try to open the `` file located in the target-definition folder. There should be a `Set as active target platform` in the top right, click that and rebuild your environment. This should fix your issue.
Best regards
Previous Topic:Failed to install deployment package of kura-greenhouse-demo in kura
Next Topic:/CONF-V1/PUT/configurations/PositionService not working
Goto Forum:

Current Time: Thu Aug 06 00:45:03 GMT 2020

Powered by FUDForum. Page generated in 0.02096 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top