Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Setting up new developer environment - 14k+ errors?(Is the default Oomph environment meant to work?)
Setting up new developer environment - 14k+ errors? [message #1819616] Sat, 18 January 2020 14:46 Go to next message
D Southwick is currently offline D SouthwickFriend
Messages: 3
Registered: January 2020
Junior Member
Hello,

Beginner here - I'd like to try and follow your Hello World example, however using the most recent version of eclipse Oomph setup yields 14,790 errors on the default view, before clicking anything.

I attempted the very first step for the Hello World tutorial, but it seems the Automated dependency management / MANIFEST.MF is restricted to ONLY org.eclipse.kura.* plugins in your default Oomph profile.

Is this a problem with recent eclipse? is the tutorial simply way out of date?

What's the easiest way to resolve this? use eclipse from 2017?

As is pretty obvious, I'm not a java expert, so this seems like a pretty big hurdle to debug just to get the basic tutorial tools to start the tutorial. Help ?

Re: Setting up new developer environment - 14k+ errors? [message #1819628 is a reply to message #1819616] Sun, 19 January 2020 06:41 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31543
Registered: July 2009
Senior Member
Sorry, I'm not sure exactly what you tried and did. The installer's simple mode only creates an installation, not a workspace. Perhaps you switched to advanced model and used one of the various project setups as well, but those are not for "Hello World" examples; those are setups of various Eclipse projects that will be entirely focused on developing the source code for those projects. If you want to start working on Java as a beginner, install just the Eclipse IDE for Java Developers, start with an empty workspace, and Google for a good introductory for Eclipse Java tutorial.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Setting up new developer environment - 14k+ errors? [message #1819631 is a reply to message #1819628] Sun, 19 January 2020 10:20 Go to previous message
D Southwick is currently offline D SouthwickFriend
Messages: 3
Registered: January 2020
Junior Member
gah - sorry this is meant for eclipse Kura - I realised after I clicked submit that I cannot edit until it came out of moderation. :(
Previous Topic:How are licenses enforced on products built on eclipse
Next Topic:Eclipse IDE for C++ - Silent / Unattended install
Goto Forum:
  


Current Time: Sat Oct 24 04:08:51 GMT 2020

Powered by FUDForum. Page generated in 0.03410 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top