Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Polarsys » Capella General » XHTML generation exception(XHTML stop the generation at this exception : Error: org.eclipse.egf.core.producer.InvocationException See your Log file for further details)
XHTML generation exception [message #1819049] Mon, 06 January 2020 10:35 Go to next message
Nesrine Badache is currently offline Nesrine BadacheFriend
Messages: 3
Registered: December 2019
Junior Member
Hi,

I m using Capella 1.3.1 with the latest XHTML add-on "CapellaXHTMLDocGen-1.3.2.201912021712-Capella-1.3.1".
The generation has the following issues:
- The logo (top right) is not displayed
- The generation stops at SA layer with the following error messages (cf the attached image - Captured_XHTML_ISSUE). LA and PA display "CETTE PAGE NE PEUT PAS ETRE AFFICHER"
- The error log says : "Error: org.eclipse.egf.core.producer.InvocationException See your Log file for further details."

I updated EMF Query (and kept the initial installation and changed with the updated elements)

Has anyone faced this issue? Any help?
Regards,
NB
Re: XHTML generation exception [message #1819396 is a reply to message #1819049] Tue, 14 January 2020 14:45 Go to previous messageGo to next message
Arnaud Dieumegard is currently offline Arnaud DieumegardFriend
Messages: 27
Registered: June 2010
Junior Member
Hi,

Quote:

- The logo (top right) is not displayed


In the Eclipse browser it may indeed be the case but it is good in external browsers. We still have to figure out why it does not work for the Eclipse web browser. Can you please confirm this behavior on your side ?

Quote:

- The generation stops at SA layer with the following error messages (cf the attached image - Captured_XHTML_ISSUE). LA and PA display "CETTE PAGE NE PEUT PAS ETRE AFFICHER"


These errors shall not be the reason for the generation to stop. Do you have additional stack trace in the "An error occured during the export action" error ?

Can you please also provide the complete log content for the empty text error for the org.eclipse.egf.pattern plugin ? (the first error in your error log)

Quote:

- The error log says : "Error: org.eclipse.egf.core.producer.InvocationException See your Log file for further details."


I cannot reproduce this error, do you have a sample model with this behavior to share ? At least the viewpoints activated on the model ?

Quote:

I updated EMF Query (and kept the initial installation and changed with the updated elements)


Did you tried with a clean new Capella 1.3.1 and a fresh install of the Capella DocGen ? Can you share information about your installation : Other plugins / addons / viewpoints installed ?

Regards,
Arnaud
Re: XHTML generation exception [message #1819405 is a reply to message #1819396] Tue, 14 January 2020 16:23 Go to previous messageGo to next message
Nesrine Badache is currently offline Nesrine BadacheFriend
Messages: 3
Registered: December 2019
Junior Member
Hi Arnaud,

Attached a screenshoot with the errors and the .txt with the details of the 4 errors. ( ALL_errors , Detailed_errors_logs)

I already tried the start from scrath on a new Capella 1.3.1 environment.
Attached the installation details (Installation_details_1 and Installation_details_2).

Thank you for your help.
Regards,

Nesrine



Re: XHTML generation exception [message #1819706 is a reply to message #1819405] Tue, 21 January 2020 17:53 Go to previous messageGo to next message
Arnaud Dieumegard is currently offline Arnaud DieumegardFriend
Messages: 27
Registered: June 2010
Junior Member
Hi Nesrine,

On your error log, the first three errors are linked to the XHTML DocGen.

The first is the one that stops the documentation generation.
This error is about integrating images in the description field of elements (more precisely in your stack trace I can see that it is on the description of an ExchangeItem element).
Images integration seems to be broken somehow in your case. I tried on my side to add some images on a model and did not notice any problems when generating the documentation.
- Are the images stored in the project workspace or elsewhere ?
- How do you add images to your description using the richtext editor ? (copy/paste, use the dedicated image integration tool)

Regarding the two others errors, it seems that the diagram export has failed. Maybe your diagrams are not refreshed, can you try to open them and save the model again ?

Regards,
Arnaud
Re: XHTML generation exception [message #1820540 is a reply to message #1819706] Wed, 22 January 2020 12:37 Go to previous message
Nesrine Badache is currently offline Nesrine BadacheFriend
Messages: 3
Registered: December 2019
Junior Member
Hello Arnaud,

thank you for your analysis. Here are my answers:
- I add images in the descriptions sections by Copy/Past them
- I don't store the images in a specific folder as I copy/past them. I absolutely don't know where they are stored even when I check the propertie section
I tried to delete all the images added in the exchange items of my project to see if it solves the issue.

Here are the errors and logs, attached to this post.
Do you have any suggestion?
Thank you for your help
Regards
Nesrine

Previous Topic:Operational Capability features (links / traceability)
Next Topic:When will the Capella source code be available again?
Goto Forum:
  


Current Time: Wed Dec 02 19:47:20 GMT 2020

Powered by FUDForum. Page generated in 0.01547 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top