Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Non-default Perspective Content no Showing(Fragment UI)
Non-default Perspective Content no Showing [message #1818133] Fri, 06 December 2019 22:12 Go to next message
Jun He is currently offline Jun HeFriend
Messages: 1
Registered: December 2019
Junior Member
Hi,

I am currently development an Eclipse 4 RCP application which has multiple perspectives.

When I exported the application and installed in a system, which has Java 8, application ran without any problems.

Then I installed application in a system using Java 10, things start getting wired. After I launched the application, default perspective was running with no errors. However, I switch perspective to non-default ones, content that defined in fragment.e4xmi are missing. Only the menu bar and perspective menu bar were appearing.

The tricky part is, this installation actually is a update of our product. Before this update, the older version of our application can run in Java 10 without any problems. The older version also has multiple perspectives.

I had include fragment.e4xmi in plugin.xml.
build.properties' bin.includes also has fragment.e4xmi

Does anybody have any ideas about how to fix this?

Thanks,

Jun
Re: Non-default Perspective Content no Showing [message #1818348 is a reply to message #1818133] Fri, 13 December 2019 07:50 Go to previous message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 179
Registered: April 2012
Senior Member
Are there any errors in the error-log?
Previous Topic:missing constraint: Import package: javax.xml.stream; version
Next Topic:Deployment decisions for an exported RCP Product
Goto Forum:
  


Current Time: Thu Nov 26 13:26:19 GMT 2020

Powered by FUDForum. Page generated in 0.01923 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top