Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Can you and how to connect to azure devops git supported?
Can you and how to connect to azure devops git supported? [message #1814500] Thu, 12 September 2019 11:08 Go to next message
stuart mellanby is currently offline stuart mellanbyFriend
Messages: 23
Registered: July 2009
Junior Member
Hi,

Can you connect to azure devops git repos using eclipse? using your login, not generated git credentials.

if so how?

thanks,

Stu
Re: Can you and how to connect to azure devops git supported? [message #1814538 is a reply to message #1814500] Thu, 12 September 2019 20:05 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 240
Registered: August 2016
Senior Member
Loaded question :-)

Azure Devops is what used to be called TFS, right? AFAIK, TFS out of the box is configured only for NTLM authentication over HTTP. JGit does not do NTLM, and we have no plans to add support for it. We're not going to invest time to support a broken protocol of which even Microsoft says new applications shouldn't use it. (They say so in their very own NTLM specification.)

Possible solutions I know of are:

  • Use SSH. Users will probably have to upload an SSH public key to the server first. (Once.) Don't know if the server needs special configuration to enable SSH access.
  • Use Kerberos (SPNEGO), either with HTTP(S) or SSH. Difficult to configure on server and client side.
  • Make sure your server is accessible only over HTTPS and enable basic authentication in the server.
  • Use a proxy like cntlm on the client side. Don't know if that works reliably.

Please see the TFS/Azure Devops manuals for how exactly to do any of these. Once the server (or the cntlm proxy) is configured, JGit can clone/fetch from it, or push to it.

(Caveat: I have personally never had to work with TFS.)
Re: Can you and how to connect to azure devops git supported? [message #1819508 is a reply to message #1814538] Thu, 16 January 2020 13:04 Go to previous message
gb gb is currently offline gb gbFriend
Messages: 1
Registered: January 2020
Junior Member
I had this problem cross domains.
the EGIT works fine conneting to tfs- git when they are on the same domain, probably related to the AD authentication.
but when came via proxy from another domain it was always "not authorized"
I asked from the network guys to disable the proxy for a while (just for me) and in eclipse proxy settings in "manual" I set the proxy definitions directly to the tfs address and it works.

Now waiting for the proxy guy to do his magic at the proxy definitions to do the same
to be continued......
Previous Topic:Switching Branches after Refactoring
Next Topic:.gitignore_global, Eclipse has git but terminal says not installed?
Goto Forum:
  


Current Time: Tue Jun 02 02:54:28 GMT 2020

Powered by FUDForum. Page generated in 0.03179 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top