Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » AUT not detected by rcptt.runner 2.4.2(Unable to launch aut using rcptt runnner 2.4.2 )
AUT not detected by rcptt.runner 2.4.2 [message #1810992] Fri, 23 August 2019 06:50 Go to next message
raghu ns is currently offline raghu nsFriend
Messages: 7
Registered: May 2019
Junior Member
I am trying to execute my tests using rcptt runner command. I get the below error:
AUT-0:Launching
AUT-0:Product: null
AUT-0:Application: null
AUT-0:Architecture: x86_64
64bit arch is selected because AUT uses launcher library
"plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.551.v20171108-1834" specified in config file: eclipse.ini
D:\aut-SDP-0: AUT arguments: -os ${target.os} -arch ${target.arch} -consoleLog
AUT-0: Launch failed. Reason: Failed to launch AUT since there is no Product and Application ID found.
AUT-0: For more information check AUT output at 'D:\rcpttRunnerWorkspace\aut-SDP-0_console.log'
Failed to launch AUT:AUT-0: Launch failed. Reason: Failed to launch AUT since there is no Product and Application ID found.

But when i tried to add the aut path in rcptt 2.4.2, it gets identified and gets added.

Any pointers to solving the issue will be helpful.
Thanks.
Re: AUT not detected by rcptt.runner 2.4.2 [message #1814499 is a reply to message #1810992] Thu, 12 September 2019 09:26 Go to previous messageGo to next message
sangeeta patil is currently offline sangeeta patilFriend
Messages: 6
Registered: February 2018
Junior Member
Hi,
Even I am facing this issue on RCPTT 2.4.2.In fact clicking the finish button while configuring AUT is not possible
Reason: Failed to launch AUT since there is no Product and Application ID found.

When i tried to add the same aut path using older versions of RCPTT,it is succesful

any helpwill be appreciated
Re: AUT not detected by rcptt.runner 2.4.2 [message #1814531 is a reply to message #1814499] Thu, 12 September 2019 18:04 Go to previous messageGo to next message
raghu ns is currently offline raghu nsFriend
Messages: 7
Registered: May 2019
Junior Member
Hi Sangeeta,

Your issue might be because of the equinox launcher. My experience has been, equinox launcher of RCPTT has to be same version as that of AUT equinox launcher.

[Updated on: Fri, 13 September 2019 06:11]

Report message to a moderator

Re: AUT not detected by rcptt.runner 2.4.2 [message #1814550 is a reply to message #1814531] Fri, 13 September 2019 05:41 Go to previous message
sangeeta patil is currently offline sangeeta patilFriend
Messages: 6
Registered: February 2018
Junior Member
Thanks !
I will check this
Previous Topic: AUT does not have focus during test execution
Next Topic:Eclipse Kepler (4.3) and RCPTT
Goto Forum:
  


Current Time: Thu Apr 25 08:56:22 GMT 2024

Powered by FUDForum. Page generated in 0.03751 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top