Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Error message run I tried to run the hello world in java(Error message)
Error message run I tried to run the hello world in java [message #1809203] Thu, 11 July 2019 12:47 Go to next message
Sergeant Smiley is currently offline Sergeant SmileyFriend
Messages: 1
Registered: July 2019
Junior Member
Why do I get this message when I tried to run a java program? What do I need to do so this won't continue to happen when I'm trying to run my Java program in Eclipse?

error occurred during initialization of boot layerjava.lang.module.findexception: error reading module: c:\coderepository\myproject\bincaused by: java.lang.module.invalidmoduledescriptorexception: myclass.class found in top-level directory (unnamed package not allowed in module)
Re: Error message run I tried to run the hello world in java [message #1809213 is a reply to message #1809203] Thu, 11 July 2019 16:47 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3510
Registered: July 2009
Senior Member

Declare your class as being in a package, using the package keyword, or don't have a module-info.java and cause it to be treated like a Java module.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Error message run I tried to run the hello world in java [message #1814019 is a reply to message #1809213] Sun, 01 September 2019 19:15 Go to previous messageGo to next message
MICHAEL DAVIS is currently offline MICHAEL DAVISFriend
Messages: 1
Registered: September 2019
Junior Member
while trying to run eclipse hello world I got the error

java.lang.module.InvalidModuleDescriptorException:

I saw an answer on the forum but I am new to eclipse and haven't programed in Java in a couple of years (BlueJ), in other words I didn't understand the answer. I need baby steps please.

Re: Error message run I tried to run the hello world in java [message #1814050 is a reply to message #1814019] Mon, 02 September 2019 10:13 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30543
Registered: July 2009
Senior Member
No one can do anything with an attached .class file. Did you try declaring your class to have a package? This is a good reference:

https://www.vogella.com/tutorials/Eclipse/article.html
Previous Topic:Unable to install SonarLint plugin
Next Topic:Installation on Server for multi-users lab help
Goto Forum:
  


Current Time: Tue Oct 15 07:05:00 GMT 2019

Powered by FUDForum. Page generated in 0.03423 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top