Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Problem with dependency resolution in PDE 2019-06?(My build works in 2019-03 but not in 06)
Problem with dependency resolution in PDE 2019-06? [message #1808293] Fri, 21 June 2019 08:02 Go to next message
Oliver Gardiner is currently offline Oliver GardinerFriend
Messages: 33
Registered: May 2014
Location: Oxford, UK
Member
I've just picked up the 06 release of PDE - have been using 03 to build a RCP application based on Papyrus. In 06, Tycho fails to load any of the declared repositories in POM.xml (although it does find the repo in the target platform stage). I have switched back to 03 in a clean workspace and it works fine. Has anything changed?

Thanks,

Oliver
Re: Problem with dependency resolution in PDE 2019-06? [message #1808323 is a reply to message #1808293] Fri, 21 June 2019 14:03 Go to previous messageGo to next message
Oliver Gardiner is currently offline Oliver GardinerFriend
Messages: 33
Registered: May 2014
Location: Oxford, UK
Member
Having successfully built under 03 it's now started building with 06 with no change to the code base or config - very odd but presumably a problem my end!
Re: Problem with dependency resolution in PDE 2019-06? [message #1809947 is a reply to message #1808323] Fri, 26 July 2019 07:46 Go to previous messageGo to next message
chao chen is currently offline chao chenFriend
Messages: 13
Registered: June 2019
Junior Member
Are you building from source code?
Re: dependency resolution in PDE 2019-06, m2e, tycho [message #1817191 is a reply to message #1808293] Mon, 18 November 2019 10:10 Go to previous message
Thomas Berger is currently offline Thomas BergerFriend
Messages: 2
Registered: February 2019
Junior Member
Yes, in fact I have the same problem: Tycho build fails to even resolve plugins provided by the Eclipse platform. The issue does not appear in 2019-03, first appears with 2019-06. I have tried 2019-09 and 2019-12M2 but no luck.

I found this bug report:
2019-09 uses maven 3.6.1 which has this bug:
https://issues.apache.org/jira/browse/MNG-6669
The issue was fixed with maven 3.6.2.

And I see, that 2019-03 (org.eclipse.m2e.maven.runtime) plugin uses maven 3.5.3, and switches to maven 3.6.1 starting with 2019-06.

Unfortunately, M2E maven version has not been updated for 2019-06/09/12, it is still using maven 3.6.1.

I am not sure how to report this?
regards


is part of plugins\org.eclipse.m2e.maven.runtime_1.13.0.20190716-1623\jars
11/05/2019 12:02 PM 57,847 maven-artifact-3.6.1.jar
11/05/2019 12:02 PM 14,583 maven-builder-support-3.6.1.jar
11/05/2019 12:02 PM 290,696 maven-compat-3.6.1.jar
11/05/2019 12:02 PM 633,079 maven-core-3.6.1.jar
11/05/2019 12:02 PM 99,003 maven-embedder-3.6.1.jar
11/05/2019 12:02 PM 185,549 maven-model-3.6.1.jar
11/05/2019 12:02 PM 179,106 maven-model-builder-3.6.1.jar
11/05/2019 12:02 PM 47,627 maven-plugin-api-3.6.1.jar
11/05/2019 12:02 PM 27,458 maven-repository-metadata-3.6.1.jar
11/05/2019 12:02 PM 149,522 maven-resolver-api-1.3.3.jar
11/05/2019 12:02 PM 44,126 maven-resolver-connector-basic-1.3.3.jar
11/05/2019 12:02 PM 182,174 maven-resolver-impl-1.3.3.jar
11/05/2019 12:02 PM 66,515 maven-resolver-provider-3.6.1.jar
11/05/2019 12:02 PM 36,733 maven-resolver-spi-1.3.3.jar
11/05/2019 12:02 PM 31,059 maven-resolver-transport-wagon-1.3.3.jar
11/05/2019 12:02 PM 159,195 maven-resolver-util-1.3.3.jar
11/05/2019 12:02 PM 44,502 maven-settings-3.6.1.jar
11/05/2019 12:02 PM 43,062 maven-settings-builder-3.6.1.jar
11/05/2019 12:02 PM 166,562 maven-shared-utils-3.2.1.jar

[Updated on: Mon, 18 November 2019 10:26]

Report message to a moderator

Previous Topic:RCPTT linux compatibility
Next Topic:Http Whiteboard propertytypes annotation support
Goto Forum:
  


Current Time: Thu Aug 06 07:50:33 GMT 2020

Powered by FUDForum. Page generated in 0.02114 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top