Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to open Eclipse Marketplace in Eclipse Jee 2019-03
Unable to open Eclipse Marketplace in Eclipse Jee 2019-03 [message #1808288] Fri, 21 June 2019 06:29 Go to next message
Geoff Alexander is currently offline Geoff AlexanderFriend
Messages: 28
Registered: November 2013
Junior Member
I installed Eclipse Jee 2019-03 via the Eclipse Installer on Windows 10 about a week ago. When I try to open the Eclipse Marketplace (Help -> Eclipse Marketplace...), I get the following error:

Cannot open Eclipse Marketplace
Cannot install remote marketplace locations: loading constraint violation when resolving method "org/apache/http/impl/client/HttpClientBuilder.setConnectionManager(Lorg/apache/http/conn/HttpClientConnectionManager;)Lorg/apache/http/impl/client/HttpClientBuilder;" : loader "org/eclipse/osgi/internal/loader/EquinoxClassLoader@2acb6b8e" of class "org/apache/http/client/fluent/Executor" and loader "org/eclipse/osgi/internal/loader/EquinoxClassLoader@270cc443" of class "org/apache/http/impl/client/HttpClientBuilder" have different types for the method signature
loading constraint violation when resolving method "org/apache/http/impl/client/HttpClientBuilder.setConnectionManager(Lorg/apache/http/conn/HttpClientConnectionManager;)Lorg/apache/http/impl/client/HttpClientBuilder;" : loader "org/eclipse/osgi/internal/loader/EquinoxClassLoader@2acb6b8e" of class "org/apache/http/client/fluent/Executor" and loader "org/eclipse/osgi/internal/loader/EquinoxClassLoader@270cc443" of class "org/apache/http/impl/client/HttpClientBuilder" have different types for the method signature
loading constraint violation when resolving method "org/apache/http/impl/client/HttpClientBuilder.setConnectionManager(Lorg/apache/http/conn/HttpClientConnectionManager;)Lorg/apache/http/impl/client/HttpClientBuilder;" : loader "org/eclipse/osgi/internal/loader/EquinoxClassLoader@2acb6b8e" of class "org/apache/http/client/fluent/Executor" and loader "org/eclipse/osgi/internal/loader/EquinoxClassLoader@270cc443" of class "org/apache/http/impl/client/HttpClientBuilder" have different types for the method signature
loading constraint violation when resolving method "org/apache/http/impl/client/HttpClientBuilder.setConnectionManager(Lorg/apache/http/conn/HttpClientConnectionManager;)Lorg/apache/http/impl/client/HttpClientBuilder;" : loader "org/eclipse/osgi/internal/loader/EquinoxClassLoader@2acb6b8e" of class "org/apache/http/client/fluent/Executor" and loader "org/eclipse/osgi/internal/loader/EquinoxClassLoader@270cc443" of class "org/apache/http/impl/client/HttpClientBuilder" have different types for the method signature


Is this a known problem? If so, how do I fix the problem. If not, where/how should I report the problem?

[Updated on: Fri, 21 June 2019 06:30]

Report message to a moderator

Re: Unable to open Eclipse Marketplace in Eclipse Jee 2019-03 [message #1808302 is a reply to message #1808288] Fri, 21 June 2019 09:15 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30540
Registered: July 2009
Senior Member
It would be best to install 2019-06 (or update to it) because for this version MPC uses newer versions of the Apache libraries.
Re: Unable to open Eclipse Marketplace in Eclipse Jee 2019-03 [message #1808322 is a reply to message #1808302] Fri, 21 June 2019 14:00 Go to previous message
Geoff Alexander is currently offline Geoff AlexanderFriend
Messages: 28
Registered: November 2013
Junior Member
Thanks for the reply. I tried to installed Eclipse 2019-06, but ran into a problem. See my Installer fails with JVM Crash post. I plan to try installing Eclipse 2019-06 from a package file rather than the Eclipse installer to see if that works.
Previous Topic:Unable to install updates in Eclipse Jee 2019-03
Next Topic:make: *** [main.rel] Error 1
Goto Forum:
  


Current Time: Mon Oct 14 04:20:39 GMT 2019

Powered by FUDForum. Page generated in 0.03713 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top