Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Error installing 2019-6
Error installing 2019-6 [message #1808267] Thu, 20 June 2019 19:15 Go to next message
Vlad Dumitrescu is currently offline Vlad DumitrescuFriend
Messages: 430
Registered: July 2009
Location: Gothenburg
Senior Member
Hi!

On one of my machines, when I try to install 2019-6, I get an error like below. I tried to clean up the p2 pool and everything, but it's still the same. I hope someone can give me a hint about what is wrong.

I am installing a plain "for commiters" profile.

best regards,
Vlad

ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found.
  at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:280)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.resolve(ProfileTransactionImpl.java:425)
  at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:337)
  at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:751)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3824)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3752)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3733)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3626)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:575)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:701)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
  ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1561056549272
  ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: Eclipse IDE for Eclipse Committers 4.12.0.20190509-1619 (epp.package.committers 4.12.0.20190509-1619) requires 'org.eclipse.equinox.p2.iu; org.eclipse.equinox.p2.user.ui.feature.group [2.4.400.v20190423-1203,2.4.400.v20190423-1203]' but it could not be found
  ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: Eclipse IDE for Eclipse Committers 4.12.0.20190529-1916 (epp.package.committers 4.12.0.20190529-1916) requires 'org.eclipse.equinox.p2.iu; org.eclipse.platform.feature.group [4.12.0.v20190522-1800,4.12.0.v20190522-1800]' but it could not be found
  ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: Eclipse IDE for Eclipse Committers 4.12.0.20190605-2143 (epp.package.committers 4.12.0.20190605-2143) requires 'org.eclipse.equinox.p2.iu; org.eclipse.help.feature.group [2.2.600.v20190531-0245,2.2.600.v20190531-0245]' but it could not be found
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1561056549272
    ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; epp.package.committers [4.12.0,5.0.0)

[Updated on: Thu, 20 June 2019 19:16]

Report message to a moderator

Re: Error installing 2019-6 [message #1808275 is a reply to message #1808267] Thu, 20 June 2019 22:05 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30553
Registered: July 2009
Senior Member
If I look with the repository explorer at

http://download.eclipse.org/technology/epp/packages/2019-06/

then I see this IU:

<unit id='epp.package.committers' version='4.12.0.20190614-1200'>

So I get the sense that (perhaps because of network failures) an older cached version of this repo (or the release train repo) is being used with an older version "epp.package.committers 4.12.0.20190509-1619" and this can't be found, because that's no longer visible in the current EPP packages repo.

Perhaps you could try deleting ~/.p2/org.eclipse.equinox.p2.repository/cache and see if there are network failures...

Re: Error installing 2019-6 [message #1808277 is a reply to message #1808275] Thu, 20 June 2019 22:33 Go to previous messageGo to next message
Vlad Dumitrescu is currently offline Vlad DumitrescuFriend
Messages: 430
Registered: July 2009
Location: Gothenburg
Senior Member
Thanks Ed,

but I deleted the whole ~/.p2 without success, I get the same error.

The "Eclipse platform" profile can be installed, but not any other (of those I tried). It looks indeed it's a caching issue, but what other places than ~/.p2 are there?

I even reinstalled the installer.

best regards,
Vlad
Re: Error installing 2019-6 [message #1808295 is a reply to message #1808277] Fri, 21 June 2019 08:49 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30553
Registered: July 2009
Senior Member
Note that https://bugs.eclipse.org/bugs/show_bug.cgi?id=548467 was opened for this problem. To summarize, specifically deleting this file should fix the problem:

~/.eclipse/org.eclipse.oomph.p2/cache/http___download.eclipse.org_technology_epp_packages_2019-06_p2.index

The underlying problem is that the server is serving stale content, i.e., .an older server-side cached version of a file for which it should yield a 404 instead:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=548497
Re: Error installing 2019-6 [message #1808297 is a reply to message #1808295] Fri, 21 June 2019 08:56 Go to previous message
Vlad Dumitrescu is currently offline Vlad DumitrescuFriend
Messages: 430
Registered: July 2009
Location: Gothenburg
Senior Member
Indeed, that fixes it. Thank you very much!
best regards,
Vlad
Previous Topic:using variable in setup preference task : possible ?
Next Topic:There's something wrong with my Eclipse installing
Goto Forum:
  


Current Time: Mon Oct 21 17:19:12 GMT 2019

Powered by FUDForum. Page generated in 0.02460 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top