Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse lunching problem(Eclipse won't lunch after installing )
Eclipse lunching problem [message #1805883] Fri, 26 April 2019 12:32 Go to next message
jacki stan is currently offline jacki stanFriend
Messages: 4
Registered: April 2019
Junior Member
Hello guys i've installed eclipse for linux mint 9 and i launch it after installation after exiting from the program, the ide won't launch anymore i can't find where to lunch it tried to lunch org.eclipse.equinox.launcher_1.5.300.v20190213-1655
nothing happened, tried to launch eclipse luncher it give me this" The Eclipse Executable launcher was unable to locate its companion shared library"
its funny that an IDE won't launch after Installing it tho it worked at the end of the installation from the green lunch button

[Updated on: Mon, 29 April 2019 10:21]

Report message to a moderator

Re: Eclipse lunching problem [message #1805920 is a reply to message #1805883] Sun, 28 April 2019 03:39 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30372
Registered: July 2009
Senior Member
What's in the eclipse-ini of your installation? It will contain a -vm option and if you're failing to launch, it perhaps points at an inappropriate version of Java so you could try pointing it at the version of Java you want it to use.
Re: Eclipse lunching problem [message #1805925 is a reply to message #1805920] Sun, 28 April 2019 08:33 Go to previous messageGo to next message
jacki stan is currently offline jacki stanFriend
Messages: 4
Registered: April 2019
Junior Member
When i finished the installation i got a lunch button and it lunched just fine the problem is that idk how to lunch it and from where i don't think the problem from java because the eclipse worked from the lunch button when it finished installation my java version is 12.0.1

Eclipse.ini:
-startup
plugins/org.eclipse.equinox.launcher_1.5.300.v20190213-1655.jar
--launcher.library
/root/.p2/pool/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.1000.v20190125-2016
-product
org.eclipse.epp.package.cpp.product
-showsplash
org.eclipse.epp.package.common
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vm
/usr/lib/jvm/java-11-openjdk-amd64/bin
-vmargs
-Dosgi.requiredJavaVersion=1.8
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
--add-modules=ALL-SYSTEM
-Dosgi.requiredJavaVersion=1.8
-Dosgi.dataAreaRequiresExplicitInit=true
-Xms256m
-Xmx1024m
--add-modules=ALL-SYSTEM
-Declipse.p2.max.threads=10
-Doomph.update.url=http://download.eclipse.org/oomph/updates/milestone/latest
-Doomph.redirection.index.redirection=index:/->http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/plain/setups/

[Updated on: Sun, 28 April 2019 09:33]

Report message to a moderator

Re: Eclipse lunching problem [message #1805933 is a reply to message #1805925] Mon, 29 April 2019 03:13 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30372
Registered: July 2009
Senior Member
The -vm argument's value suggests to me that it's using "/usr/lib/jvm/java-11-openjdk-amd64/bin", i.e., Java 11. But this value should be the same value that was used to launch the installer and that launched okay. You can try changing this value to another version of Java you have on your machine or removing it so that Eclipse will use whatever is on your PATH.
Re: Eclipse lunching problem [message #1805939 is a reply to message #1805933] Mon, 29 April 2019 07:15 Go to previous messageGo to next message
jacki stan is currently offline jacki stanFriend
Messages: 4
Registered: April 2019
Junior Member
Thank you i fixed th problem yesterday ♥️
Re: Eclipse lunching problem [message #1805940 is a reply to message #1805939] Mon, 29 April 2019 07:47 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30372
Registered: July 2009
Senior Member
For the benefit of my understanding and the next guy with the problem, what did you do to fix the problem in your case?
Re: Eclipse lunching problem [message #1805948 is a reply to message #1805940] Mon, 29 April 2019 10:15 Go to previous message
jacki stan is currently offline jacki stanFriend
Messages: 4
Registered: April 2019
Junior Member
I tried reinstalling it more than one time but what fixed it is not pressing the launch button when the installation finished i just opened the executable launcher from the eclipse folder and cancelled the installation window... wired i know but it worked
Previous Topic:Payara Tools plugin for Eclipse won't install
Next Topic:The code of method eIsSet(int) is exceeding the 65535 bytes limit
Goto Forum:
  


Current Time: Sun Aug 25 06:34:26 GMT 2019

Powered by FUDForum. Page generated in 0.03472 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top