Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Trouble launching Eclipse Help System from program files dir(Launches fine from C:\, but not from C:\Program Files)
Trouble launching Eclipse Help System from program files dir [message #1805532] Tue, 16 April 2019 20:27 Go to next message
Kyla Town is currently offline Kyla TownFriend
Messages: 4
Registered: April 2019
Junior Member
Hello,

I am using Eclipse version 2019-03 (4.11.0) to create a standalone help system for a non-Eclipse product.

I have been trying to launch the Eclipse Help System from C:Program Files\CompanyDir\ProductDir\DocDir\DocAudience\Plugins, but I receive the error: Could not find or load main class org.eclipse.help.standaloneHelp.

I cd to C:\Program Files\CompanyDir\ProductDir\DocDir\DocAudience which is the root directory of the Eclipse installation directory.

Then I run the command:
java -classpath C:\Program Files\CompanyDir\ProductDir\DocDir\DocAudience\plugins\org.eclipse.help.base_[version].jar org.eclipse.help.standalone.Help -command displayHelpWindow

The base help jar file is on my classpath. I can open the Eclipse application from Program Files, but not the Help System.

I can open the help system from directories outside of Program Files, but not from our Program Files directory.
Re: Trouble launching Eclipse Help System from program files dir [message #1805539 is a reply to message #1805532] Wed, 17 April 2019 05:53 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30542
Registered: July 2009
Senior Member
Your error message says 'org.eclipse.help.standaloneHelp" where there appears to be a . missing before Help. Is that a typo? Also be careful with file names with spaces in them. Do you need quotes around the classpath's argument so that it's not interpreted as two arguments?
Re: Trouble launching Eclipse Help System from program files dir [message #1805574 is a reply to message #1805539] Wed, 17 April 2019 14:37 Go to previous message
Kyla Town is currently offline Kyla TownFriend
Messages: 4
Registered: April 2019
Junior Member
The problem was the space in the path. Thank you so much!!!
Previous Topic:Eclipse does not work please help asap
Next Topic:Launch an eclipse application missing in version 4.9
Goto Forum:
  


Current Time: Tue Oct 15 04:57:44 GMT 2019

Powered by FUDForum. Page generated in 0.02907 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top