Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » CZ keyboard - mapping of certain characters does not work(CZ keyboard - mapping of certain characters does not work)
CZ keyboard - mapping of certain characters does not work [message #1803961] Thu, 14 March 2019 11:41 Go to next message
Patrik Hanak is currently offline Patrik HanakFriend
Messages: 6
Registered: February 2019
Junior Member
Hi !

I would need to test RCP application with Czech keyboard layout so I prepared cs_CZ.properties file.
Keyboard works well for digits and small letters with diacritics, but I am not able to define correct
mappings for certain characters:


    Capital letters with diacritics ( eg. Á ). While typing, they are written as sequence of keystrokes ( ex. Á is written as sequence of accute_accent (English = key) and shift + a). It is not clear, how to define sequence of keystrokes in properties file

    Forward slash (/) . While typing, it is written as shift + ú on CZ keyboard. I tried the following mappings in properties file:
    /=shift+[ 
    /=shift+ú 
    but I was not able to generate forward slash during the test. Other special characters like )!"( I have not tested yet.


Please can you help with the issues above ?

I use the following configuration:
OS: MS Windows 7
Jubula: 8.7.1

Thanks in advance.
Re: CZ keyboard - mapping of certain characters does not work [message #1804139 is a reply to message #1803961] Tue, 19 March 2019 08:36 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 194
Registered: March 2012
Senior Member
Hello Patrik,

Indeed i have found a Problem[1].I can fix this today and can give you a drop in replacement, this will be attached to the ticket[1].

I have also attached the cs_CZ.properties which will work after i finished fixing the Bug.

Additionally there are some characters which must be escaped(see Documentation[2])

best regards
Marvin Mueller


[1] http://eclip.se/545529
[2] https://help.eclipse.org/2018-12/topic/org.eclipse.jubula.client.ua.help/content/html/developerManual/keyboardLayout/ch07.html
Re: CZ keyboard - mapping of certain characters does not work [message #1804166 is a reply to message #1804139] Tue, 19 March 2019 15:34 Go to previous messageGo to next message
Patrik Hanak is currently offline Patrik HanakFriend
Messages: 6
Registered: February 2019
Junior Member
Hello Marvin,

thanks for the fix, it helped to solve the second issue ( the one with forward slash).

Unfortunately, the issue with capital letters with diacritics still persists. I think the problem is unclear way how to define sequence of keystrokes in keyboard layout file. I do not mean a keystroke with modifier ( like ctrl/alt/shift) but real sequence of several keystrokes needed to generate capital letters with diacritics. It is not described in Reference Manual. I tried:
Á=´+shift+a
for Á , but it did not work.

Please, can you help with this as well ?
Re: CZ keyboard - mapping of certain characters does not work [message #1804240 is a reply to message #1804166] Thu, 21 March 2019 06:27 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 194
Registered: March 2012
Senior Member
Hello Patrik,

I had a short look into it, and this is at this moment definitely not working. We are supporting only Modifier keys + one character.Since this is more effort, i will work on this earliest next week.

best regards
Marvin Mueller
Re: CZ keyboard - mapping of certain characters does not work [message #1806856 is a reply to message #1804240] Thu, 16 May 2019 11:43 Go to previous messageGo to next message
Patrik Hanak is currently offline Patrik HanakFriend
Messages: 6
Registered: February 2019
Junior Member
Hello Marvin,

I tried to test Czech keyboard with new rcp accessor (org.eclipse.jubula.rc.rcp_7.0.2.201904020816.jar) using the following steps:
1. remove previous version of rcp accessor from AUT plugins directory and config.ini file
2. add new rcp accessor to AUT plugins directory and config.ini file
3. run AUT with -clean switch

but the test case failed with "Configuration Error" - see attached rc_rcp_error.log. Jubula was not able to click on toolbar button which worked well before.
I tried to repeat object mapping for the toolbar button but it failed with error - see attached mapping_error.log.

Any hints how to continue ?

best regards
Patrik Hanak
Re: CZ keyboard - mapping of certain characters does not work [message #1807020 is a reply to message #1806856] Tue, 21 May 2019 10:17 Go to previous messageGo to next message
Marvin Mueller is currently offline Marvin MuellerFriend
Messages: 194
Registered: March 2012
Senior Member
Did you also used the fixed version for the jubula api/ITE [1]


[1] http://eclip.se/545529
Re: CZ keyboard - mapping of certain characters does not work [message #1807346 is a reply to message #1807020] Tue, 28 May 2019 11:03 Go to previous message
Patrik Hanak is currently offline Patrik HanakFriend
Messages: 6
Registered: February 2019
Junior Member
Hello Marvin,

yes, I used the fixed version of the client API.

Br

Patrik Hanak
Previous Topic:Working with tables
Next Topic:"Error occurred" closing a window
Goto Forum:
  


Current Time: Mon Dec 16 09:45:59 GMT 2019

Powered by FUDForum. Page generated in 0.07463 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top