Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Titan » Bug in titan.ProtocolModules.BSSMAP and/or RAW codec?
Bug in titan.ProtocolModules.BSSMAP and/or RAW codec? [message #1802832] Sun, 17 February 2019 19:27 Go to next message
Harald Welte is currently offline Harald WelteFriend
Messages: 89
Registered: July 2017
Location: Berlin, Germany
Member

I'm currently experiencing some strange behavior with the BSSMAP protocol module from git://git.eclipse.org/gitroot/titan/titan.ProtocolModules.BSSMAP_v11.2.0

When I try to parse the octetstring '0004200401098F'O with it, it fails to recognize that the '8F' at the end is actually the optional 'CSFB Indicator' IE of the PDU_BSSMAP_ClearCommand.

This is strange, as I believe the definition of PDU_BSSMAP_ClearCommand including the BSSMAP_IE_CSFB_Indication is actually correct.

However when feeding the above-mentioned octetstring into dec_PDU_BSSAP(), the result is:

{ discriminator := '0'B, spare := '0000000'B, dlci := omit, lengthIndicator := 4, pdu := { bssmap := { clearCommand := { messageType := '20'O (" "), layer3HeaderInfo := omit, cause := { elementIdentifier := '04'O, lengthIndicator := 1, causeValue := '0001001'B, extensionCauseValue := '0'B, spare1 := omit }, cSFB_Indication := omit } } } }

note that cSFB_Indication should not be omit!

Also:
20:07:35.430508 MSC_Tests.ttcn:4543 dec_PDU_BSSAP(): Warning: Data remained at the end of the stream after successful decoding: '8F'O

i.e. the RAW codec somehow doesn't recognize the 8F as CSFB Indication.

Any help is much appreciated. I actually suspect a bug of the RAW codec here?

Thanks in advance
Re: Bug in titan.ProtocolModules.BSSMAP and/or RAW codec? [message #1802862 is a reply to message #1802832] Mon, 18 February 2019 09:54 Go to previous messageGo to next message
Gábor Szalai is currently offline Gábor SzalaiFriend
Messages: 35
Registered: December 2015
Member
The length of the layer 3, BSSMAP message ('200401098F'O) is 5 not 4, so the length indicator in the BSSAP part should be '05':


'0005200401098F'O


{ discriminator := '0'B, spare := '0000000'B, dlci := omit, lengthIndicator := 5, pdu := { bssmap := { clearCommand := { messageType := '20'O (" "), layer3HeaderInfo := omit, cause := { elementIdentifier := '04'O, lengthIndicator := 1, causeValue := '0001001'B, extensionCauseValue := '0'B, spare1 := omit }, cSFB_Indication := { elementIdentifier := '8F'O } } } } }
Re: Bug in titan.ProtocolModules.BSSMAP and/or RAW codec? [message #1802866 is a reply to message #1802862] Mon, 18 February 2019 10:56 Go to previous message
Harald Welte is currently offline Harald WelteFriend
Messages: 89
Registered: July 2017
Location: Berlin, Germany
Member

Ok, now I seriously feel stupid. Thanks a lot. Sometimes it really helps for another set of eyes to look at a problem. Also thanks for your super fast response!
Previous Topic:ASN.1 PER encoding of EUTRA_RRC_ASN1_Definitions.asn ?
Next Topic:PTCs on different machines
Goto Forum:
  


Current Time: Thu Dec 12 21:37:07 GMT 2019

Powered by FUDForum. Page generated in 0.01945 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top