Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » 2018-12 Eclipse Installation Error ( Unable to read repository at http://download.eclipse.org/releases/2018-12/201812191000/content.xml.xz.)
2018-12 Eclipse Installation Error [message #1801211] Tue, 15 January 2019 12:03 Go to next message
Freddy Kugelmass is currently offline Freddy KugelmassFriend
Messages: 5
Registered: December 2018
Junior Member
Hi everybody.
This is happening to me both in 2018-09 and 2018-12.
When installing, I get this error:
Unable to read repository at http://download.eclipse.org/releases/2018-12/201812191000/content.xml.xz.

I could manage to install 2018-09 with the offline download, but can't upgrade or update, nor install extra products (I use WindowBuilder a lot!)

Complete log from installer (2018-12) follows:

INSTALLATION LOG
[2019-01-15 08:37:18] Executing bootstrap tasks
[2019-01-15 08:37:18] Java(TM) SE Runtime Environment 1.8.0_191-b12
[2019-01-15 08:37:18] Product org.eclipse.products.epp.package.java.2018-12
[2019-01-15 08:37:18] Bundle org.eclipse.oomph.setup 1.10.0.v20180914-1031, build=3784, branch=d5b911e1f3bc20f8e0c54af3126d8150fbc53bdf
[2019-01-15 08:37:18] Bundle org.eclipse.oomph.setup.core 1.11.0.v20181203-0741, build=3784, branch=d5b911e1f3bc20f8e0c54af3126d8150fbc53bdf
[2019-01-15 08:37:18] Bundle org.eclipse.oomph.setup.p2 1.10.0.v20180706-1242, build=3784, branch=d5b911e1f3bc20f8e0c54af3126d8150fbc53bdf
[2019-01-15 08:37:18] Performing P2 Director (Eclipse IDE for Java Developers (2018-12))
[2019-01-15 08:37:18] Offline = false
[2019-01-15 08:37:18] Mirrors = true
[2019-01-15 08:37:18] Resolving 23 requirements from 3 repositories to E:\eclipse 2018\eclipse
[2019-01-15 08:37:18] Requirement epp.package.java [4.10.0,5.0.0)
[2019-01-15 08:37:18] Requirement org.eclipse.platform.feature.group [4.10.0,5.0.0)
[2019-01-15 08:37:18] Requirement org.eclipse.rcp.feature.group [4.10.0,5.0.0)
[2019-01-15 08:37:18] Requirement org.eclipse.buildship.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.eclemma.feature.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.egit.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.egit.mylyn.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.epp.mpc.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.jdt.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.jgit.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.m2e.feature.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.m2e.logback.feature.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.mylyn.bugzilla_feature.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.mylyn.context_feature.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.mylyn.git.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.mylyn.hudson.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.mylyn.ide_feature.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.mylyn.java_feature.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.mylyn.wikitext_feature.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.mylyn_feature.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.tips.feature.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.wst.xml_ui.feature.feature.group
[2019-01-15 08:37:18] Requirement org.eclipse.oomph.setup.feature.group
[2019-01-15 08:37:18] Repository http://download.eclipse.org/technology/epp/packages/2018-12
[2019-01-15 08:37:18] Repository http://download.eclipse.org/releases/2018-12/201812191000
[2019-01-15 08:37:18] Repository http://download.eclipse.org/oomph/updates/milestone/latest
[2019-01-15 08:37:28] ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 Unable to read repository at http://download.eclipse.org/releases/2018-12/201812191000/content.xml.xz.
org.apache.http.TruncatedChunkException: Truncated chunk ( expected size: 32768; actual size: 4072)
at org.apache.http.impl.io.ChunkedInputStream.read(ChunkedInputStream.java:198)
at java.util.zip.InflaterInputStream.fill(Unknown Source)
at java.util.zip.InflaterInputStream.read(Unknown Source)
at java.util.zip.GZIPInputStream.read(Unknown Source)
at org.apache.http.client.entity.LazyDecompressingInputStream.read(LazyDecompressingInputStream.java:70)
at org.apache.http.conn.EofSensorInputStream.read(EofSensorInputStream.java:135)
at java.io.FilterInputStream.read(Unknown Source)
at java.io.FilterInputStream.read(Unknown Source)
at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer$1.performFileTransfer(AbstractRetrieveFileTransfer.java:178)
at org.eclipse.ecf.filetransfer.FileTransferJob.run(FileTransferJob.java:74)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

[2019-01-15 08:37:28]
[2019-01-15 08:45:30] Executing bootstrap tasks
[2019-01-15 08:45:30] Java(TM) SE Runtime Environment 1.8.0_191-b12
[2019-01-15 08:45:30] Product org.eclipse.products.epp.package.java.2018-12
[2019-01-15 08:45:30] Bundle org.eclipse.oomph.setup 1.10.0.v20180914-1031, build=3784, branch=d5b911e1f3bc20f8e0c54af3126d8150fbc53bdf
[2019-01-15 08:45:30] Bundle org.eclipse.oomph.setup.core 1.11.0.v20181203-0741, build=3784, branch=d5b911e1f3bc20f8e0c54af3126d8150fbc53bdf
[2019-01-15 08:45:30] Bundle org.eclipse.oomph.setup.p2 1.10.0.v20180706-1242, build=3784, branch=d5b911e1f3bc20f8e0c54af3126d8150fbc53bdf
[2019-01-15 08:45:30] Performing P2 Director (Eclipse IDE for Java Developers (2018-12))
[2019-01-15 08:45:30] Offline = false
[2019-01-15 08:45:30] Mirrors = true
[2019-01-15 08:45:30] Resolving 23 requirements from 3 repositories to E:\eclipse 2018\eclipse
[2019-01-15 08:45:30] Requirement epp.package.java [4.10.0,5.0.0)
[2019-01-15 08:45:30] Requirement org.eclipse.platform.feature.group [4.10.0,5.0.0)
[2019-01-15 08:45:30] Requirement org.eclipse.rcp.feature.group [4.10.0,5.0.0)
[2019-01-15 08:45:30] Requirement org.eclipse.buildship.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.eclemma.feature.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.egit.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.egit.mylyn.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.epp.mpc.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.jdt.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.jgit.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.m2e.feature.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.m2e.logback.feature.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.mylyn.bugzilla_feature.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.mylyn.context_feature.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.mylyn.git.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.mylyn.hudson.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.mylyn.ide_feature.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.mylyn.java_feature.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.mylyn.wikitext_feature.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.mylyn_feature.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.tips.feature.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.wst.xml_ui.feature.feature.group
[2019-01-15 08:45:30] Requirement org.eclipse.oomph.setup.feature.group
[2019-01-15 08:45:30] Repository http://download.eclipse.org/technology/epp/packages/2018-12
[2019-01-15 08:45:30] Repository http://download.eclipse.org/releases/2018-12/201812191000
[2019-01-15 08:45:30] Repository http://download.eclipse.org/oomph/updates/milestone/latest
[2019-01-15 08:45:36] ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 Unable to read repository at http://download.eclipse.org/releases/2018-12/201812191000/content.xml.xz.
org.apache.http.TruncatedChunkException: Truncated chunk ( expected size: 16394; actual size: 10234)
at org.apache.http.impl.io.ChunkedInputStream.read(ChunkedInputStream.java:198)
at java.util.zip.InflaterInputStream.fill(Unknown Source)
at java.util.zip.InflaterInputStream.read(Unknown Source)
at java.util.zip.GZIPInputStream.read(Unknown Source)
at org.apache.http.client.entity.LazyDecompressingInputStream.read(LazyDecompressingInputStream.java:70)
at org.apache.http.conn.EofSensorInputStream.read(EofSensorInputStream.java:135)
at java.io.FilterInputStream.read(Unknown Source)
at java.io.FilterInputStream.read(Unknown Source)
at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer$1.performFileTransfer(AbstractRetrieveFileTransfer.java:178)
at org.eclipse.ecf.filetransfer.FileTransferJob.run(FileTransferJob.java:74)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

[2019-01-15 08:45:36]


Operating system: Windows 10 - x64.
Java 8-191 (compilation 1.8.0_191-b12)

Previous versions has no problem installing.

Looks like the file content.xml.xz doesn't download correctly.

Help will be appreciated
Re: 2018-12 Eclipse Installation Error [message #1801218 is a reply to message #1801211] Tue, 15 January 2019 14:56 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30620
Registered: July 2009
Senior Member
Sorry, I can point you at two related bugzilla:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=539316
https://bugs.eclipse.org/bugs/show_bug.cgi?id=515596

It may well be the case that you are being redirected to a mirror with bad content. And there's nothing you can do to control to which mirror the Eclipse server redirects your p2 repository access...

You can only hope that with repeated attempts you'll eventually get the contents from a good mirror. :-(
Re: 2018-12 Eclipse Installation Error [message #1801222 is a reply to message #1801218] Tue, 15 January 2019 15:22 Go to previous messageGo to next message
Freddy Kugelmass is currently offline Freddy KugelmassFriend
Messages: 5
Registered: December 2018
Junior Member
Well.... it looks like I will re-retry until the carpal tunnel syndrome hits me again...
Re: 2018-12 Eclipse Installation Error [message #1801226 is a reply to message #1801222] Tue, 15 January 2019 15:50 Go to previous messageGo to next message
Eitan Rosenberg is currently offline Eitan RosenbergFriend
Messages: 28
Registered: October 2018
Junior Member
Hi,

Just my two cents worth of remarks...

Have you ever try to download a zip file from:
https://www.eclipse.org/downloads/packages/

and then verify the file using the SHA-512 .

The installation is just unzipping the file to a folder of your choice.

e.g.
https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/2018-12/R/eclipse-jee-2018-12-R-win32-x86_64.zip

Will take you here:

You need to click on the "sha-512" button

index.php/fa/34665/0/

Regards.
Re: 2018-12 Eclipse Installation Error [message #1801227 is a reply to message #1801226] Tue, 15 January 2019 15:56 Go to previous messageGo to next message
Freddy Kugelmass is currently offline Freddy KugelmassFriend
Messages: 5
Registered: December 2018
Junior Member
Hi Eitan,
I did that. But happens the same as with 2018-09: I can't update or install new packages, because of the same reason.

Using the advance installation I retry several times, and I get always the same result but with different size now: it truncates at 10234.

Maybe I have to wait sometime until I have a new mirror ...
Will keep on trying.

Thanks for the advice
Re: 2018-12 Eclipse Installation Error [message #1801232 is a reply to message #1801227] Tue, 15 January 2019 16:18 Go to previous messageGo to next message
Eitan Rosenberg is currently offline Eitan RosenbergFriend
Messages: 28
Registered: October 2018
Junior Member
Hi,

Just for testing I just download
https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/2018-12/R/eclipse-java-2018-12-R-win32-x86_64.zip&mirror_id=1190
Checksum OK !!!

It was from Germany - University of Erlangen-Nuremberg (http) (I am from Israel)

You were saying "Maybe I have to wait sometime until I have a new mirror ..."
you can decide on a different mirror

Good luck !
Re: 2018-12 Eclipse Installation Error [message #1801268 is a reply to message #1801232] Wed, 16 January 2019 05:02 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30620
Registered: July 2009
Senior Member
Yes, but the point is that even if you download a package creation your installation that way, if later you want to install anything into that package, you will use the same p2 technology to access the same Eclipse.org server and will encounter the same issues trying to update or install any additional software, and Freddy already mentioned that is one of his goals/tasks.
Re: 2018-12 Eclipse Installation Error [message #1801281 is a reply to message #1801268] Wed, 16 January 2019 07:01 Go to previous message
Eitan Rosenberg is currently offline Eitan RosenbergFriend
Messages: 28
Registered: October 2018
Junior Member
Hi,

Thanks for the lesson.

I knew that here I will learn new things.

Regards.
Previous Topic:Apache Directory Studio Plugin
Next Topic:I don't get the new pricing system
Goto Forum:
  


Current Time: Tue Nov 12 16:32:59 GMT 2019

Powered by FUDForum. Page generated in 0.01928 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top