Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Is there a way to upgrade POI in BIRT runtime 4.7+(Is there a way to upgrade POI in BIRT runtime 4.7+)
Is there a way to upgrade POI in BIRT runtime 4.7+ [message #1800012] Wed, 19 December 2018 03:17 Go to next message
Jim Tzeng is currently offline Jim TzengFriend
Messages: 1
Registered: December 2018
Junior Member
Hi,

Out project have both POI 3.17 & Birt Runtime 4.8 (POI 3.9), and encountered problem like below exception stack.
The reason we include POI 3.17 is because of "CVE-2017-12626".

Any solution to change inner POI 3.9?

Caused by: org.eclipse.birt.report.engine.api.EngineException: Error happened while running the report.
at org.eclipse.birt.report.engine.api.impl.EngineTask.handleFatalExceptions(EngineTask.java:2392)
at org.eclipse.birt.report.engine.api.impl.RunAndRenderTask.doRun(RunAndRenderTask.java:191)
at org.eclipse.birt.report.engine.api.impl.RunAndRenderTask.run(RunAndRenderTask.java:77)
at common.platform.birt.config.BirtView.renderMergedOutputModel(BirtView.java:142)
at org.springframework.web.servlet.view.AbstractView.render(AbstractView.java:304)
at org.springframework.web.servlet.DispatcherServlet.render(DispatcherServlet.java:1286)
at org.springframework.web.servlet.DispatcherServlet.processDispatchResult(DispatcherServlet.java:1041)
at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:984)
at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:901)
at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:970)
... 113 more
Caused by: java.lang.NoSuchFieldError: RETURN_NULL_AND_BLANK
at org.apache.poi.xssf.usermodel.XSSFWorkbook.<init>(XSSFWorkbook.java:147)
at uk.co.spudsoft.birt.emitters.excel.XlsxEmitter.createWorkbook(XlsxEmitter.java:43)
at uk.co.spudsoft.birt.emitters.excel.ExcelEmitter.start(ExcelEmitter.java:210)
at org.eclipse.birt.report.engine.emitter.CompositeContentEmitter.start(CompositeContentEmitter.java:225)
at org.eclipse.birt.report.engine.api.impl.RunAndRenderTask.doRun(RunAndRenderTask.java:180)
... 121 more
Re: Is there a way to upgrade POI in BIRT runtime 4.7+ [message #1826745 is a reply to message #1800012] Wed, 29 April 2020 19:33 Go to previous message
Lucas Santos is currently offline Lucas SantosFriend
Messages: 5
Registered: September 2018
Junior Member
Were you able to solve this?
Right now we are trying to upgrade some libraries that have vulnerabilities and poi 3.13 is one of those but Birt won't work with 3.17 (at least what I found)

It would be helpful to know if you were able to fix that.

Thank you
Previous Topic:Files data handling[Stored in Database as binary data] in birt
Next Topic:Eclipse RCP Dynamic help customization
Goto Forum:
  


Current Time: Tue Sep 22 15:58:04 GMT 2020

Powered by FUDForum. Page generated in 0.02554 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top