Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse wont start
Eclipse wont start [message #1799941] Mon, 17 December 2018 17:33 Go to next message
doudou doudou is currently offline doudou doudouFriend
Messages: 2
Registered: December 2018
Junior Member
Hi,
I have a problem with Eclipse when I try to start it I get an error message that says the following:
An error has occurred. See the log file /home/doudou/eclipse-workspace/.metadata/.log
I have installed Eclipse cpp version and after I added a couple plugins it started showing me this error message.
I do need both Java and C/C++ development tools and language support and also the modeling frameworks for my studies.
I do use Linux ( Manjaro) and download Eclipse from its repository and tried to reinstall but I still get the same error.
index.php/fa/34520/0/
  • Attachment: .log
    (Size: 390.39KB, Downloaded 68 times)
  • Attachment: Eclipse.png
    (Size: 6.06KB, Downloaded 194 times)
Re: Eclipse wont start [message #1799958 is a reply to message #1799941] Tue, 18 December 2018 04:54 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31005
Registered: July 2009
Senior Member
These errors all look related to the fact that javax.xml.bind has been removed from Java 11. You could avoid that by using Java 8 instead. You could add (or modify) two lines like this in your eclipse.ini to use an older JVM
-vm
C:/Program Files/Java/jdk1.8.0_121/jre/bin
Of course you'd use the path to the bin folder of an older JDK/JRE actually on your machine. Before sure to put it before -vmargs section in the eclipse.ini, on two separate lines; the the start of the file should work well.
Re: Eclipse wont start [message #1799998 is a reply to message #1799958] Tue, 18 December 2018 17:51 Go to previous message
doudou doudou is currently offline doudou doudouFriend
Messages: 2
Registered: December 2018
Junior Member
Ed Merks wrote on Tue, 18 December 2018 04:54

Thanks for your reply I did uninstall opendjdk11/openjre11 and installed openjdk8/openjre8 and now eclipse is working :)
Thanks for your help
Previous Topic:How to Install Java Eclipse in Citrix Multiple User environment
Next Topic:[RCPTT] Suite execution stops after test verification failure
Goto Forum:
  


Current Time: Tue Mar 31 17:40:45 GMT 2020

Powered by FUDForum. Page generated in 0.03970 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top