Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Multiple dependency chain error for package in same bundle
Multiple dependency chain error for package in same bundle [message #1798656] Thu, 22 November 2018 07:53 Go to next message
Jaseem  M is currently offline Jaseem MFriend
Messages: 2
Registered: November 2018
Junior Member
When I try to deploy a subsystem which uses camel, I am getting this exception.
AFAIK this will be thrown if same package is being imported from different bundles transitively. That doesn't seem to the case here. javax.net.ssl is being imported from the same bundle in both the scenarios.

Why would this happen?

org.osgi.service.subsystem.SubsystemException: org.osgi.service.resolver.ResolutionException: Uses constraint violation. Unable to resolve resource TestComponent.TestComponent [/tmp/inputStreamExtract4777560061446980492.zip/TestComponent-1.0.1-SNAPSHOT.jar] because it is exposed to package 'javax.net.ssl' from resources org.eclipse.osgi [org.eclipse.osgi_3.8.2.v20130124-134944] and org.eclipse.osgi [org.eclipse.osgi_3.8.2.v20130124-134944] via two dependency chains.

Chain 1:
  TestComponent.TestComponent [/tmp/inputStreamExtract4777560061446980492.zip/TestComponent-1.0.1-SNAPSHOT.jar]
    import: (&(osgi.wiring.package=javax.net.ssl)(version>=0.0.0))
     |
    export: osgi.wiring.package: javax.net.ssl
  org.eclipse.osgi [org.eclipse.osgi_3.8.2.v20130124-134944]

Chain 2:
  TestComponent.TestComponent [/tmp/inputStreamExtract4777560061446980492.zip/TestComponent-1.0.1-SNAPSHOT.jar]
    import: (&(osgi.wiring.package=org.apache.camel.impl)(version>=2.14.0))
     |
    export: osgi.wiring.package=org.apache.camel.impl; uses:=javax.net.ssl
  org.apache.camel.camel-core [org.apache.camel.camel-core_2.17.4]
    import: (&(osgi.wiring.package=javax.net.ssl))
     |
    export: osgi.wiring.package: javax.net.ssl
  org.eclipse.osgi [org.eclipse.osgi_3.8.2.v20130124-134944]



Thanks in advance,
Jaseem
Re: Multiple dependency chain error for package in same bundle [message #1798842 is a reply to message #1798656] Mon, 26 November 2018 14:36 Go to previous messageGo to next message
Thomas Watson is currently offline Thomas WatsonFriend
Messages: 502
Registered: July 2009
Senior Member
That is either a bug in the framework implementation (org.eclipse.osgi_3.8.2.v20130124-134944) which is very old at this point, or you may have multiple copies of org.eclipse.osgi_3.8.2.v20130124-134944 in your environment. Perhaps your subsystem is trying to package org.eclipse.osgi_3.8.2.v20130124-134944 also?

I suggest you try updating to the latest release of Equinox.
Re: Multiple dependency chain error for package in same bundle [message #1798988 is a reply to message #1798842] Wed, 28 November 2018 10:59 Go to previous message
Jaseem  M is currently offline Jaseem MFriend
Messages: 2
Registered: November 2018
Junior Member
We don't have multiple copies of the bundle, so it seems like a bug in the old version of equinox.

Thanks for the reply,
Jaseem

Previous Topic:Performance degradation after upgrade from org.eclipse.osgi 3.9.1 to higher versions 3.10+
Next Topic:Create p2 site mirror without references to origin sites
Goto Forum:
  


Current Time: Sun Nov 27 13:38:29 GMT 2022

Powered by FUDForum. Page generated in 0.02063 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top