Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse SmartHome » OSGi test problem: missing constraints
OSGi test problem: missing constraints [message #1798002] Fri, 09 November 2018 23:21 Go to next message
Dominik Schlierf is currently offline Dominik SchlierfFriend
Messages: 6
Registered: November 2018
Junior Member
Hello everyone :)

I just added an OSGi test to my new Time Condition, but when I try to run the test configuration in org.eclipse.smarthome.automation.module.timer.test it gives me the message that theres a missing constraint. One of these is the import package org.eclipse.smarthome.test. When I add this package to the run configuration plug ins I get even more missing constraints.

Can anyone tell me what I am doing wrong?
Re: OSGi test problem: missing constraints [message #1798098 is a reply to message #1798002] Mon, 12 November 2018 12:53 Go to previous messageGo to next message
Henning Treu is currently offline Henning TreuFriend
Messages: 44
Registered: April 2017
Member
Hi Dominik,

the launch configs sometimes get outdated so the process you already started is the way to go: Add org.eclipse.smarthome.test to the import packages and you probably have to add javax.servlet along with some jetty packages. You are welcome to also contribute the updated launch config with your PR.

Cheers,
Henning
Re: OSGi test problem: missing constraints [message #1798198 is a reply to message #1798098] Wed, 14 November 2018 06:16 Go to previous message
Dominik Schlierf is currently offline Dominik SchlierfFriend
Messages: 6
Registered: November 2018
Junior Member
Oh ok, thank you - I will update it as soon as possible then! :)
Previous Topic:Need help understanding the rules engine implementation
Next Topic:ESH + Authorisation + OPTIONS method
Goto Forum:
  


Current Time: Fri Apr 03 06:56:56 GMT 2020

Powered by FUDForum. Page generated in 0.05981 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top