Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » 'the feature ownedlinemappings is not a valid reference' message
'the feature ownedlinemappings is not a valid reference' message [message #1795957] Wed, 03 October 2018 05:02 Go to next message
Prajna VGFriend
Messages: 54
Registered: July 2018
Member
Hi,

I imported a sirius project created in other system. I added a table representation and rows and columns to that viewpoint. But when I close that design file and open again I am getting a message
Problems encountered -the feature ownedlinemappings is not a valid reference '
and all my changes gets deleted

index.php/fa/33992/0/

index.php/fa/33993/0/

I tried so many time. But if I close and again open that design file it gives that message.

[Updated on: Wed, 03 October 2018 05:26]

Report message to a moderator

Re: 'the feature ownedlinemappings is not a valid reference' message [message #1795978 is a reply to message #1795957] Wed, 03 October 2018 13:19 Go to previous messageGo to next message
Steve Monnier is currently offline Steve MonnierFriend
Messages: 505
Registered: May 2011
Senior Member
Hello,

How did you install Sirius on the new system? The EReference "ownedlinemappings" has been present in the Table metamodel for a long time so it should not be a difference of version between your systems.

Regards,
Steve


Steve Monnier - Obeo
Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: 'the feature ownedlinemappings is not a valid reference' message [message #1797331 is a reply to message #1795978] Tue, 30 October 2018 04:19 Go to previous message
Prajna VGFriend
Messages: 54
Registered: July 2018
Member
After creating so many times, the problem solved by giving unique id for line. The id which we were giving was same for some lines or nodes. If we give unique id which is not used before in design the problem will not occur.. :)

[Updated on: Tue, 30 October 2018 04:19]

Report message to a moderator

Previous Topic:How to populate the obeo model through the api?
Next Topic:Builtin LFS problem
Goto Forum:
  


Current Time: Sat Feb 27 04:41:06 GMT 2021

Powered by FUDForum. Page generated in 0.02141 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top