Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » APP4MC » Problem with the File "rover082.amxmi"
Problem with the File "rover082.amxmi" [message #1792646] Fri, 20 July 2018 13:50 Go to next message
Lei Wang is currently offline Lei WangFriend
Messages: 1
Registered: June 2018
Junior Member
Hello everyone,

i am a new fan of APP4MC. Recently i have met a problem during learning this software. From this links "" i have downloaded the file "rover082.amxmi". It looks great, when i do the partitioning and task generation process. But after mapping, there was always fault, see as the figure shows.
During the Process i havent changed anything, i.e. the pre-partitiong method--> "group runable via activations", partitioning method-->"ESSP with 4 partitions" and mapping algorithm-->"ILP based load balancing". And i use the APP4MC 0.8.2. Other Visions 0.8.3 and 0.9.0 also i have tried, but the same error.
Anyone has the same problem? Looking forward to every reply.

Re: Problem with the File "rover082.amxmi" [message #1809524 is a reply to message #1792646] Wed, 17 July 2019 11:13 Go to previous messageGo to next message
Chaitanya Kasipally is currently offline Chaitanya KasipallyFriend
Messages: 2
Registered: May 2019
Junior Member
Hi Lei Wang,
Iam facing the same error as you mentioned while generating mapping to the AmaltheaESSPwithTasks model
Iam excited to know whether you resolved the error now
If so,Kindly requesting you to help me how can I resolve this error

Re: Problem with the File "rover082.amxmi" [message #1810622 is a reply to message #1809524] Wed, 14 August 2019 13:23 Go to previous message
Lukas Krawczyk is currently offline Lukas KrawczykFriend
Messages: 3
Registered: August 2019
Junior Member


thanks for the detailed description, I was capable to reproduce this error with App4MC-0.8.3, which contains the last working version of the OpenMapping plugin.

This behaviour caused by re-creating the OS model, i.e. the old OS model with semaphores is being deleted and replaced by one without semaphores, hence the broken references. Unless you strictly rely on semaphores, you can safely ignore these errors / warnings and continue with e.g. the TaskVisualizer in order to visualize the execution.

Unfortunately, support for the Open Mapping Plugin was dropped after version 0.8.3 due to it's complexity. We are however working on a replacement that will likely replace it in 2020.

Best regards,

Previous Topic:Unable to find partition,mapping plugin in amalthea
Next Topic:Modeling off-chip communication
Goto Forum:

Current Time: Sat Mar 02 01:32:14 GMT 2024

Powered by FUDForum. Page generated in 0.03337 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top