Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » Strange behavior when specifying config.ini
Strange behavior when specifying config.ini [message #33880] Tue, 18 November 2008 19:24
Brad is currently offline BradFriend
Messages: 5
Registered: July 2009
Junior Member
First off, if this in the wrong forum let me know I will repost elsewhere.

In my "Run Configurations" with the Eclipse IDE I am specifying a
config.ini file to use as a "template" when running my RCP app. I can
specify the start levels, etc... using my config file. This has always
worked fine up until now.

Recently I had the need to add two more plugins to the config file.
Let's establish that:
1) You specify your config.ini file within the run configuration
2) When the configuration is run the specified config.ini is either used
as a "template" (Their words) or copied into the run configurations
specified "configuration" directory.
3) This resultant config.ini file is used to run the application/product.

Great. This works fine until I did the following until I added two new
plugins to the config.ini.

Step 2 above should copy those changes to the generate config.ini. It
doesn't. For some reason it ignores ONLY THESE TWO PLUGINS. If I make
other changes to the start levels, etc... they ARE PROPAGATED properly.

I have already:
1) Ensured I am pointing to the proper config.ini. There is no mistake
2) Re-installed eclipse
3) Wiped my workspace and started from scratch
4) And MOST IMPORTANTLY and WEIRD ...Generated a completely new config.ini
and set start levels. I did this by having Eclipse "Generate a config.ini
with default content". When I run using this setting my missing plugins
show in the equinox console, but I obviously can't set my start levels. I
then copy the working config.ini, set the start levels, and replace my old
config.ini that I specified in my run configuration. In theory this should
work. All the paths are correct, but once again, it ignores my two

I am at a loss. Any help is appreciated.
Previous Topic:Problem regenerating Sites
Next Topic:Strange behavior when specifying config.ini
Goto Forum:

Current Time: Mon Sep 20 15:17:34 GMT 2021

Powered by FUDForum. Page generated in 0.01269 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top