Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Oxygen Installer(Eclipse Oxygen Installer with Proxy)
Eclipse Oxygen Installer [message #1784207] Fri, 23 March 2018 14:05 Go to next message
marco giudici is currently offline marco giudiciFriend
Messages: 201
Registered: February 2013
Location: Italy
Senior Member
Hi,
I try to install Eclipse Oxygen on my laptop with Windows 7 x64 but my company use a proxy to permit the access to internet. I have this rights.
I follow the steps reported in the follow link https://www.eclipse.org/downloads/eclipse-packages/?show_instructions=TRUE
but install eclipse IDE but generate a lot of error messages linked to the proxy authorization and also when I create a project return problem about Maven with proxy.

Someone can help me and explain exactly what I need to do to configure correctly the installer and after IDE to create the project in the correct way.

Thanks in advance for any help

Marco
Re: Eclipse Oxygen Installer [message #1784219 is a reply to message #1784207] Fri, 23 March 2018 16:22 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30442
Registered: July 2009
Senior Member
It's hard to know in general about proxy settings because it depends so much on your company's proxy details. Both the installer's menu (in the upper right) and in Eclipse's Window -> Preferences -> General Network Connections give you the ability to control how network proxies are configured. The settings you change in the installer will be copied to the installation... But I can't know what's right in your company...
Re: Eclipse Oxygen Installer [message #1805467 is a reply to message #1784207] Mon, 15 April 2019 16:23 Go to previous messageGo to next message
carolina arroyave is currently offline carolina arroyaveFriend
Messages: 5
Registered: April 2019
Junior Member
Hi,

I have a similar problem.
Could you tell me please, which rules or exclusions do we have to configure, in order to install eclipse?

This is the error detail:

[2019-04-15 11:22:06] Executing bootstrap tasks
[2019-04-15 11:22:06] Java(TM) SE Runtime Environment 1.8.0_181-b13
[2019-04-15 11:22:06] Product org.eclipse.products.epp.package.jee.2019-03
[2019-04-15 11:22:06] Bundle org.eclipse.oomph.setup 1.12.0.v20190206-0943, build=3895, branch=a662e867f63d5b59dd0935621f30827543b3c0bb
[2019-04-15 11:22:06] Bundle org.eclipse.oomph.setup.core 1.12.0.v20190206-0651, build=3895, branch=a662e867f63d5b59dd0935621f30827543b3c0bb
[2019-04-15 11:22:06] Bundle org.eclipse.oomph.setup.p2 1.10.0.v20180706-1242, build=3895, branch=a662e867f63d5b59dd0935621f30827543b3c0bb
[2019-04-15 11:22:06] Performing P2 Director (Eclipse IDE for Enterprise Java Developers (2019-03))
[2019-04-15 11:22:06] Offline = false
[2019-04-15 11:22:06] Mirrors = true
[2019-04-15 11:22:06] Resolving 89 requirements from 3 repositories to D:\Murex\eclipse
[2019-04-15 11:22:06] Requirement epp.package.jee [4.11.0,5.0.0)
[2019-04-15 11:22:06] Requirement org.eclipse.platform.feature.group [4.11.0,5.0.0)
[2019-04-15 11:22:06] Requirement org.eclipse.rcp.feature.group [4.11.0,5.0.0)
[2019-04-15 11:22:06] Requirement org.eclipse.buildship.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.cft.server.core.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.cft.server.ui.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.common.doc.user.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.connectivity.doc.user.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.connectivity.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.connectivity.oda.designer.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.connectivity.oda.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.doc.user.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.apache.derby.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.hsqldb.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.ibm.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.ingres.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.jdbc.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.jdt.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.msft.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.mysql.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.oda.designer.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.oda.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.oracle.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.postgresql.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.sap.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.sdk.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.sqlite.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.enablement.sybase.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.intro.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.modelbase.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.sdk.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.sqldevtools.data.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.sqldevtools.ddl.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.sqldevtools.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.sqldevtools.parsers.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.sqldevtools.results.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.datatools.sqltools.doc.user.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.eclemma.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.egit.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.egit.mylyn.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.epp.mpc.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jdt.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jpt.common.eclipselink.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jpt.common.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jpt.jaxb.eclipselink.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jpt.jaxb.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jpt.jpa.eclipselink.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jpt.jpa.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jsf.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.common.fproj.enablement.jdt.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.enterprise_ui.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.server_adapters.ext.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.server_adapters.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.server_ui.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.web_ui.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.webpageeditor.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.ws.axis2tools.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.ws.cxf.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.ws.jaxws.dom.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.jst.ws.jaxws.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.m2e.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.m2e.logback.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.m2e.wtp.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.m2e.wtp.jaxrs.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.m2e.wtp.jpa.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.m2e.wtp.jsf.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.mylyn.bugzilla_feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.mylyn.context_feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.mylyn.ide_feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.mylyn.java_feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.mylyn.wikitext_feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.mylyn_feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.pde.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.tips.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.tm.terminal.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.wst.common.fproj.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.wst.jsdt.chromium.debug.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.wst.jsdt.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.wst.server_adapters.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.wst.web_ui.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.wst.xml_ui.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.wst.xsl.feature.feature.group
[2019-04-15 11:22:06] Requirement org.eclipse.oomph.setup.feature.group
[2019-04-15 11:22:06] Repository http://download.eclipse.org/technology/epp/packages/2019-03
[2019-04-15 11:22:06] Repository http://download.eclipse.org/releases/2019-03/201903201000
[2019-04-15 11:22:06] Repository http://download.eclipse.org/oomph/updates/milestone/latest
[2019-04-15 11:22:06] ERROR: org.eclipse.equinox.p2.metadata.repository code=1002 Unable to read repository at http://download.eclipse.org/oomph/updates/milestone/latest.
java.io.IOException: http://download.eclipse.org/oomph/updates/milestone/latest is not a valid repository location.
at org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepositoryFactory.load(CompositeMetadataRepositoryFactory.java:114)
at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.factoryLoad(MetadataRepositoryManager.java:63)
at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:770)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.oomph.util.ReflectUtil.invokeMethod(ReflectUtil.java:117)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:409)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:201)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager$Metadata.loadRepository(CachingRepositoryManager.java:476)
at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:110)
at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:105)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$RepositoryLoader$Worker.perform(ProfileTransactionImpl.java:1613)
at org.eclipse.oomph.util.WorkerPool$Worker.run(WorkerPool.java:428)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
Re: Eclipse Oxygen Installer [message #1805473 is a reply to message #1805467] Mon, 15 April 2019 18:58 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30442
Registered: July 2009
Senior Member
I don't know what an "exclusion" rule is... Are you behind a proxy that "excludes" some URLs? In general, don't exclude anything from download.eclipse.org...
Re: Eclipse Oxygen Installer [message #1805729 is a reply to message #1805473] Mon, 22 April 2019 19:32 Go to previous messageGo to next message
carolina arroyave is currently offline carolina arroyaveFriend
Messages: 5
Registered: April 2019
Junior Member
Hi
Security area let me access to this url but i continue with The problem.
Maybe could you send me please, all The urls that I need to have access in order to install, thank you very much
Re: Eclipse Oxygen Installer [message #1805741 is a reply to message #1805729] Tue, 23 April 2019 04:17 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30442
Registered: July 2009
Senior Member
Which URLs are accessed will depend on which version of the product you are installing, and these locations (p2 repositories) can have references to other p2 repositories. For example, https://download.eclipse.org/oomph/updates/milestone/latest/compositeContent.jar contains compositeContent.xml which currently looks like this:
<?xml version='1.0' encoding='UTF-8'?>
<?compositeMetadataRepository version='1.0.0'?>
<repository name='Oomph Latest Milestone' type='org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepository' version='1.0.0'>
  <properties size='2'>
    <property name='p2.timestamp' value='1555221281770'/>
    <property name='p2.compressed' value='false'/>
  </properties>
  <children size='1'>
    <child location='../../../drops/milestone/S20190414-014413-1.13.0-M1'/>
  </children>
</repository>
This changes when there is a new milestone build, though always to something under https://download.eclipse.org/oomph/drops/

In any case, you already see in the log which "top-level" p2 repository URLs are being accessed, and you can browse those URLs in the browser to see their contents.
Re: Eclipse Oxygen Installer [message #1805825 is a reply to message #1805741] Thu, 25 April 2019 02:01 Go to previous messageGo to next message
carolina arroyave is currently offline carolina arroyaveFriend
Messages: 5
Registered: April 2019
Junior Member
Hi

Finally we could access to The different urls, but The error changed.
Do you have any idea about this?

Error reading signed content.

java.util.zip.ZipException: Exception in opening zip file: C:\Users\cararroy\.p2\pool\plugins\org.apache.commons.codec_1.10.0.v20180409-1845.jar

at org.eclipse.osgi.framework.util.SecureAction.getZipFile(SecureAction.java:320)

at
Re: Eclipse Oxygen Installer [message #1805829 is a reply to message #1805825] Thu, 25 April 2019 03:53 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 30442
Registered: July 2009
Senior Member
Perhaps previous attempts have left garbage in your bundle pool so you could try to repair it:

https://www.eclipse.org/forums/index.php/m/1780180/?srch=repair+bundle+pool#msg_1780180

If you have no successful installations that are using your bundle pool, you could delete the entire C:\Users\cararroy\.p2 folder to start from scratch; note doing this will destroy any installations that use this bundle pool so don't make a habit of it.
Re: Eclipse Oxygen Installer [message #1805894 is a reply to message #1805829] Sat, 27 April 2019 01:54 Go to previous messageGo to next message
carolina arroyave is currently offline carolina arroyaveFriend
Messages: 5
Registered: April 2019
Junior Member
Hi, thanks for your help, finally I could install Eclipse.
Now, I have a new error when i try to add a plugin from The market place.

I appreciate if you can help me again!

Unable to read repository at https://download.springsource.com/release/TOOLS/sts4/update/e4.11/content.xml.

sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target



org.eclipse.equinox.p2.core.ProvisionException: Unable to read repository at https://download.eclipse.org/technology/epp/packages/2019-03/content.xml.

at org.eclipse.equinox.internal.p2.repository.CacheManager.createCache(CacheManager.java:246)

at org.eclipse.equinox.internal.p2.metadata.repository.SimpleMetadataRepositoryFactory.getLocalFile(SimpleMetadataRepositoryFactory.java:69)

at org.eclipse.equinox.internal.p2.metadata.repository.SimpleMetadataRepositoryFactory.load(SimpleMetadataRepositoryFactory.java:89)

at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.factoryLoad(MetadataRepositoryManager.java:63)

at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:770)

at sun.reflect.GeneratedMethodAccessor47.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at org.eclipse.oomph.util.ReflectUtil.invokeMethod(ReflectUtil.java:117)

at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:409)

at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:201)

at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager$Metadata.loadRepository(CachingRepositoryManager.java:476)

at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:110)

at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:105)

at org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepository.addChild(CompositeMetadataRepository.java:168)

at org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepository.<init>(CompositeMetadataRepository.java:110)

at org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepositoryFactory.load(CompositeMetadataRepositoryFactory.java:124)

at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.factoryLoad(MetadataRepositoryManager.java:63)

at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:770)

at sun.reflect.GeneratedMethodAccessor47.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at org.eclipse.oomph.util.ReflectUtil.invokeMethod(ReflectUtil.java:117)

at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:409)

at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:201)

at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager$Metadata.loadRepository(CachingRepositoryManager.java:476)

at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:110)

at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:105)

at org.eclipse.equinox.p2.ui.LoadMetadataRepositoryJob.doLoad(LoadMetadataRepositoryJob.java:121)

at org.eclipse.equinox.p2.ui.LoadMetadataRepositoryJob.runModal(LoadMetadataRepositoryJob.java:106)

at org.eclipse.equinox.internal.p2.ui.sdk.PreloadingRepositoryHandler$1.runModal(PreloadingRepositoryHandler.java:84)

at org.eclipse.equinox.p2.operations.ProvisioningJob.run(ProvisioningJob.java:190)

at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)

Caused by: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

at sun.security.ssl.Alerts.getSSLException(Unknown Source)

at sun.security.ssl.SSLSocketImpl.fatal(Unknown Source)

at sun.security.ssl.Handshaker.fatalSE(Unknown Source)

at sun.security.ssl.Handshaker.fatalSE(Unknown Source)

at sun.security.ssl.ClientHandshaker.serverCertificate(Unknown Source)

at sun.security.ssl.ClientHandshaker.processMessage(Unknown Source)

at sun.security.ssl.Handshaker.processLoop(Unknown Source)

at sun.security.ssl.Handshaker.process_record(Unknown Source)

at sun.security.ssl.SSLSocketImpl.readRecord(Unknown Source)

at sun.security.ssl.SSLSocketImpl.performInitialHandshake(Unknown Source)

at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)

at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)

at org.apache.http.conn.ssl.SSLSocketFactory.createLayeredSocket(SSLSocketFactory.java:573)

at org.apache.http.conn.ssl.SSLSocketFactory.createLayeredSocket(SSLSocketFactory.java:449)

at org.apache.http.impl.conn.DefaultClientConnectionOperator.updateSecureConnection(DefaultClientConnectionOperator.java:220)

at org.apache.http.impl.conn.ManagedClientConnectionImpl.layerProtocol(ManagedClientConnectionImpl.java:419)

at org.apache.http.impl.client.DefaultRequestDirector.establishRoute(DefaultRequestDirector.java:813)

at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:614)

at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:445)

at org.apache.http.impl.client.AbstractHttpClient.doExecute(AbstractHttpClient.java:835)

at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:83)

at org.eclipse.ecf.provider.filetransfer.httpclient4.HttpClientFileSystemBrowser.runRequest(HttpClientFileSystemBrowser.java:263)

at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$DirectoryJob.run(AbstractFileSystemBrowser.java:69)

... 1 more

Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

at sun.security.validator.PKIXValidator.doBuild(Unknown Source)

at sun.security.validator.PKIXValidator.engineValidate(Unknown Source)

at sun.security.validator.Validator.validate(Unknown Source)

at sun.security.ssl.X509TrustManagerImpl.validate(Unknown Source)

at sun.security.ssl.X509TrustManagerImpl.checkTrusted(Unknown Source)

at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(Unknown Source)

... 20 more

Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

at sun.security.provider.certpath.SunCertPathBuilder.build(Unknown Source)

at sun.security.provider.certpath.SunCertPathBuilder.engineBuild(Unknown Source)

at java.security.cert.CertPathBuilder.build(Unknown Source)

... 26 more

1
Re: Eclipse Oxygen Installer [message #1805895 is a reply to message #1805894] Sat, 27 April 2019 03:33 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30442
Registered: July 2009
Senior Member
This sounds like the same type of issue as this thread:

https://www.eclipse.org/forums/index.php?t=msg&th=1096677&goto=1799997&#msg_1799997

I.e., it's an issue with the certificates known/accepted by the JVM that you are using. Often installing and using a newer version of Java will solve the problem. It's also possible to add the certificate to the certificate store but that's quite a complicate procedure:

https://www.google.com/search?q=java+add+certificate+to+certificate+store
Previous Topic:Unable to Install Eclipse on MAC
Next Topic:Install & Update Nightmares
Goto Forum:
  


Current Time: Mon Sep 16 12:14:08 GMT 2019

Powered by FUDForum. Page generated in 0.03257 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top