Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » BIRT MySQL Communications link failure within Tomcat(BIRT no longer connects to my MySQL Server on a Tomcat 7 Installation)
BIRT MySQL Communications link failure within Tomcat [message #1778231] Tue, 12 December 2017 07:38
Max Meyer is currently offline Max MeyerFriend
Messages: 1
Registered: December 2017
Junior Member
I have a Tomcat 7 on CentOS 7 machine running BIRT. It all worked fine and the rptdesign files returned nice results.

The other day it simply stopped working with this Exception

exception.error ( 1 time(s) )
detail : An exception occurred during processing. Please see the following message for details:
Cannot open the connection for the driver: There is an error in get connection, Communications link failure

The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.. (Element ID:1005)
I double clicked on the data source and then manage drivers within Eclipse and added the mysql jar. But this seems to have no effect at all as Eclipse does not show any changes to the rptdesign file and so it seems that I cannot deploy this change to the birt machine. However I deployed with that change anyway => problem persists

I have checked if there is a mysql-connector.jar in the Tomcat => it is

I have checked if the mysql-connector.jar is installed via YUM => it is

I have tried to connect to the datasource in that BIRT report via mysql -hsomehostname -usomeuser -psomepass => this works

I have tried to reboot both the BIRT and MySQL machine => problem persists

I have double checked that the username and password in the connection are fine => they are

It all runs fine on my windows machine within eclipse but no longer on the CentOS 7 machine

While googeling this I only find results that tell me to add a mysql-connector.jar into this folder

My BIRT war does not contain a plugin folder within the WEB-INF folder. An I never did anything with such a folder. So I tried to add that folder and still my problem persists.

Also I found results telling me to change MySQL servers configuration to bind to all IP addresses and such but beeing able to connect via mysql -hsomehostname -usomeuser -psomepass I assume that there is no problem on the MySQL end.

Could someone please help?
Previous Topic:Cumulative Count
Next Topic:Report Exception when run on server, but no problem running locally.
Goto Forum:

Current Time: Mon Aug 03 19:30:22 GMT 2020

Powered by FUDForum. Page generated in 0.02044 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top