Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Problem installing/updating GNU ARM plugin
Problem installing/updating GNU ARM plugin [message #1760438] Thu, 27 April 2017 08:43 Go to next message
Radim Kalas is currently offline Radim KalasFriend
Messages: 1
Registered: April 2017
Junior Member
Hi,

I'm trying to install/update the GNU ARM plugin from http://gnuarmeclipse*sourceforge*net/updates but I constantly receive "HTTP Server Unknown HTTP Response Code (301):http://gnuarmeclipse*sourceforge*net/updates/content.xml".

If I try to get the file from web browser, a popup window on the sourceforge page appears with an information that the file could not be found. Indeed there is no file called "content.xml" but "content.xml.xz".

I updated my Eclipse to version 4.5.2 as I have read somewhere that the .xz is only supported starting from the 4.5 version. But it didn't help.

Any ideas?

PS. sorry for the * in the links, but I'm new here and I 'm not able to post links
Re: Problem installing/updating GNU ARM plugin [message #1760483 is a reply to message #1760438] Thu, 27 April 2017 16:09 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31961
Registered: July 2009
Senior Member
I've see this too with sourceforge update sites. I believe 301 means permanently moved. If you try http://gnuarmeclipse.sourceforge.net/updates in the browser you see it redirects to https://sourceforge.net/projects/gnuarmeclipse/files/Eclipse/updates/ and I think something has changed in the last while in how the sourceforge server works because even using https://sourceforge.net/projects/gnuarmeclipse/files/Eclipse/updates/ results in (for me SSL handshake errors). But note that if you download https://sourceforge.net/projects/gnuarmeclipse/files/Eclipse/updates/content.xml.xz/download and look at the download link of the file that you download it's been further redirected to some mirror, in my case https://netcologne.dl.sourceforge.net/project/gnuarmeclipse/Eclipse/updates/content.xml.xz and if I use https://netcologne.dl.sourceforge.net/project/gnuarmeclipse/Eclipse/updates (at least in the Repository Explorer view) that seems to load correctly. Maybe that approach will work for you as well (using whatever mirror the browser things is a good one).

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:how to get DataType values in Acceleo
Next Topic:Create an Outline view for my own language editor In Eclipse 4.x?
Goto Forum:
  


Current Time: Sat Jul 31 09:52:03 GMT 2021

Powered by FUDForum. Page generated in 0.03401 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top