Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to Add or clone a Git Repository Neon.3(GIT Integration)
Unable to Add or clone a Git Repository Neon.3 [message #1758466] Wed, 29 March 2017 01:05 Go to next message
Michael Rosenhahn is currently offline Michael RosenhahnFriend
Messages: 3
Registered: March 2017
Junior Member
On my Neon.3 system, after running the Eclipse updates, I had the following error on the Git Repositories perspective.

java.nio.file.InvalidPathException: Illegal char <"> at index 0: \.gitconfig

I deleted the .metadata folder in the workspace folder cleared the above error but I am not unable to add in the existing local Git repositories or clone an existing Git repository. Uninstalling and reinstalling Eclipse does not correct the issue.

The repositories are seen in the wizard but are not added to the perspective when finished is clicked.

I have another machine that is still running Neon.2 and it is able to view and add Git repositories as can my older Kepler machine.

Re: Unable to Add or clone a Git Repository Neon.3 [message #1758474 is a reply to message #1758466] Wed, 29 March 2017 03:08 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3796
Registered: July 2009
Senior Member

Please attach whatever is in that .pdf file directly. And you might want to look at the contents of ~/.gitconfig, which would seem to be what it's complaining about, and see if anything looks amiss.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Unable to Add or clone a Git Repository Neon.3 [message #1758530 is a reply to message #1758474] Wed, 29 March 2017 16:49 Go to previous message
Michael Rosenhahn is currently offline Michael RosenhahnFriend
Messages: 3
Registered: March 2017
Junior Member
I searched for the .gitconfig on the affected machine and the file is not present any where in the file structure.

Is there a process for recreating the .gitconfig file?

[EDIT]
I tried copying the .gitconfig from a machine that has the file over to the affected machine. It looks like Eclipse is having difficulty parsing the .gitconfig file path. It seems to be complaining about the double quotation mark (") in the file path

org.eclipse.e4.core.di.InjectionException: java.nio.file.InvalidPathException: Illegal char <"> at index 0: "C:\Users\mrosenha"\.gitconfig

[Updated on: Wed, 29 March 2017 17:46]

Report message to a moderator

Previous Topic:org.eclipse.wst.server.core is missing
Next Topic:Project closed in workspace, dependency added in ivy.xml, but still eclipse throws error
Goto Forum:
  


Current Time: Wed Aug 12 05:06:48 GMT 2020

Powered by FUDForum. Page generated in 0.03192 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top