Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Can't install(Network connection failure)
Can't install [message #1758266] Sun, 26 March 2017 10:56 Go to next message
piggy piglet is currently offline piggy pigletFriend
Messages: 3
Registered: March 2017
Junior Member
index.php/fa/28881/0/[/img]Hi, when ever I try to install eclipse neon, I get this error.
I've tried installing this many times before, always the same error. index.php/fa/28881/0/
  • Attachment: bugs.PNG
    (Size: 8.79KB, Downloaded 956 times)
Re: Can't install [message #1758282 is a reply to message #1758266] Mon, 27 March 2017 04:51 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3793
Registered: July 2009
Senior Member

Have you done the things prescribed there?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Can't install [message #1758382 is a reply to message #1758282] Tue, 28 March 2017 08:34 Go to previous messageGo to next message
piggy piglet is currently offline piggy pigletFriend
Messages: 3
Registered: March 2017
Junior Member
Yes, but I'm not using a proxy. None of it makes any sense, I just want it to connect to my internet so I can install it :/
Re: Can't install [message #1758389 is a reply to message #1758382] Tue, 28 March 2017 10:17 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31357
Registered: July 2009
Senior Member
Something is preventing the installer process from successfully downloading the setup archive:

http://www.eclipse.org/setups/setups.zip

This resource should be downloaded can cached in ~/.eclipse/org.eclipse.oomph.setup/cache/http___www.eclipse.org_setups_setups.zip. Does that folder have any contents for you. Is your firewall perhaps restricting/block network access for the installer process?


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Can't install [message #1758395 is a reply to message #1758389] Tue, 28 March 2017 11:50 Go to previous messageGo to next message
piggy piglet is currently offline piggy pigletFriend
Messages: 3
Registered: March 2017
Junior Member
I do not have a cache folder there. I'm going to try delete the .eclipse folder.

EDIT: Just tried, didn't work so i tried extracting that setups.zip into the setups folder in .eclipse, that didn't do anything either.

EDIT 2: Well, I got it working but I closed it and tried to reproduce what I did so I can help others with the same problem, so far no luck.

EDIT 3: Figured out how to reproduce but got this error on installing, https://hastebin.com/idomutozex.cs
My name is removed.

[Updated on: Tue, 28 March 2017 12:12]

Report message to a moderator

Re: Can't install [message #1758417 is a reply to message #1758395] Tue, 28 March 2017 13:47 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31357
Registered: July 2009
Senior Member
So you don't seem to have proper access to the internet. Even if you (somehow) load the setup archive, you can't read any of the p2 repositories either:

[2017-03-28 20:10:49] ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 Unable to read repository at http://download.eclipse.org/technology/epp/packages/neon/content.xml.
java.net.SocketException: Permission denied: connect

I'm not sure what kind of environment you're in, but it looks like a network problem. Mostly a firewall blocking the network or being behind a proxy with restricted access. Have you tried turning your firewall off (for testing)?


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Debugging Ruby
Next Topic:What have Eclipse system requirements?
Goto Forum:
  


Current Time: Fri Aug 07 19:47:55 GMT 2020

Powered by FUDForum. Page generated in 0.03379 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top