Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » After upgrading from neon.2 to neon.3, getting odd NCDFE from "org.eclipse.core.resources"
After upgrading from neon.2 to neon.3, getting odd NCDFE from "org.eclipse.core.resources" [message #1758219] Fri, 24 March 2017 18:45 Go to next message
David M. Karr is currently offline David M. KarrFriend
Messages: 673
Registered: July 2009
Senior Member
I had an installation of neon.2 working reasonably well. Yesterday I checked for updates and let the neon.3 upgrade install.

I first noticed that the "Marketplace" menu item went away, and I had some curious "BundleException: Could not resolve module" errors in the log.

I later discovered that running with "-clean" fixed most of this. However, I still have some remaining issues that I want to examine.

When Eclipse starts up, I now see an error dialog saying:
Errors occurred during the build.
Errors running builder 'Maven Project Builder' on project 'camunda-quickstart-spring-servlet-pa-jboss'.
org/apache/commons/compress/compressors/bzip2/BZip2CompressorInputStream


That "camunda..." project is just a project in my workspace, but I also note that I see the following in my Eclipse log:
!ENTRY org.eclipse.core.resources 4 2 2017-03-24 11:36:19.453
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.core.resources".
!STACK 0
java.lang.NoClassDefFoundError: org/apache/commons/compress/compressors/bzip2/BZip2CompressorInputStream
	at org.codehaus.plexus.archiver.tar.TarUnArchiver.<init>(TarUnArchiver.java:52)
	at org.codehaus.plexus.archiver.tar.TarGZipUnArchiver.<init>(TarGZipUnArchiver.java:37)
	at com.coderplus.utils.BuildHelper.unpack(BuildHelper.java:550)
	at com.coderplus.utils.BuildHelper.processCopyOrUnpack(BuildHelper.java:222)
	at com.ianbrandt.tools.m2e.mdp.core.MdpBuildParticipant.build(MdpBuildParticipant.java:63)
	at org.eclipse.m2e.core.internal.builder.MavenBuilderImpl.build(MavenBuilderImpl.java:137)
    ...
Caused by: java.lang.ClassNotFoundException: org.apache.commons.compress.compressors.bzip2.BZip2CompressorInputStream cannot be found by com.ianbrandt.tools.m2e.mdp.core_0.0.4.201410161303
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:461)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:372)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:364)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 29 more

!ENTRY org.eclipse.core.resources 4 75 2017-03-24 11:37:57.447
!MESSAGE Errors occurred during the build.
!SUBENTRY 1 org.eclipse.m2e.core 4 75 2017-03-24 11:37:57.447
!MESSAGE Errors running builder 'Maven Project Builder' on project 'camunda-quickstart-spring-servlet-pa-jboss'.
!STACK 0
java.lang.NoClassDefFoundError: org/apache/commons/compress/compressors/bzip2/BZip2CompressorInputStream
	at org.codehaus.plexus.archiver.tar.TarUnArchiver.<init>(TarUnArchiver.java:52)
	at org.codehaus.plexus.archiver.tar.TarGZipUnArchiver.<init>(TarGZipUnArchiver.java:37)
	at com.coderplus.utils.BuildHelper.unpack(BuildHelper.java:550)
	at com.coderplus.utils.BuildHelper.processCopyOrUnpack(BuildHelper.java:222)
	at com.ianbrandt.tools.m2e.mdp.core.MdpBuildParticipant.build(MdpBuildParticipant.java:63)
	at org.eclipse.m2e.core.internal.builder.MavenBuilderImpl.build(MavenBuilderImpl.java:137)
    ...
Caused by: java.lang.ClassNotFoundException: org.apache.commons.compress.compressors.bzip2.BZip2CompressorInputStream cannot be found by com.ianbrandt.tools.m2e.mdp.core_0.0.4.201410161303
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:461)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:372)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:364)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 29 more


In other words, this isn't just happening in my project, it's happening in a core plugin.
Re: After upgrading from neon.2 to neon.3, getting odd NCDFE from "org.eclipse.core.resources&q [message #1758241 is a reply to message #1758219] Sat, 25 March 2017 15:29 Go to previous message
David Wegener is currently offline David WegenerFriend
Messages: 1441
Registered: July 2009
Senior Member
You appear to have a third party plugin installed related to the name com.ianbrandt.tools.m2e. This would appear to be a maven build plugin that is executed as part of the Maven builder. That plugin is referencing a class that can no longer be found which would indicate that the plugin isn't compatible with the Neon.3 version of Eclipse. Your best bet would be to contact the developer of the plugin to see if they can upgrade it. Based on the plugin name, it appears to be this one:
https://github.com/ianbrandt/m2e-maven-dependency-plugin
Previous Topic:Black text on a black background
Next Topic:StackOverFlow error
Goto Forum:
  


Current Time: Thu Aug 13 03:41:28 GMT 2020

Powered by FUDForum. Page generated in 0.03318 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top