Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Markdown support?
Markdown support? [message #1753963] Mon, 13 February 2017 12:52 Go to next message
Bob Rockefeller is currently offline Bob RockefellerFriend
Messages: 5
Registered: February 2017
Location: Midway, GA
Junior Member
I'm somewhat surprised to be finding it difficult to find a well-featured Markdown plug-in for Eclipse. Something that can handle syntax highlighting, spell checking, at least.

I have the Markdwon Text Editor, but I see no way to do syntax coloring.
The FluentMark plug-in appears to only handle converting Markdown to other formats.

What tools are the experienced Eclipse folks using for Markdown?
Re: Markdown support? [message #1753977 is a reply to message #1753963] Mon, 13 February 2017 15:24 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3793
Registered: July 2009
Senior Member

A link to the "Markdwon Text Editor" might help, but I've found Winterwell's would seem to do those things: https://marketplace.eclipse.org/content/markdown-text-editor . WikiText also supports editing Markdown: https://wiki.eclipse.org/Mylyn/WikiText .

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Mon, 13 February 2017 15:26]

Report message to a moderator

Re: Markdown support? [message #1753980 is a reply to message #1753977] Mon, 13 February 2017 15:38 Go to previous messageGo to next message
Bob Rockefeller is currently offline Bob RockefellerFriend
Messages: 5
Registered: February 2017
Location: Midway, GA
Junior Member
Yes, that's the plug-in I have. It doesn't do (or seem to do) syntax highlighting.

Screenshot attached:

index.php/fa/28426/0/
  • Attachment: markdown.jpeg
    (Size: 225.12KB, Downloaded 539 times)
Re: Markdown support? [message #1753987 is a reply to message #1753980] Mon, 13 February 2017 16:45 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3793
Registered: July 2009
Senior Member

> Yes, that's the plug-in I have.
I mentioned two. Try the other one?


Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Markdown support? [message #1754028 is a reply to message #1753987] Tue, 14 February 2017 00:00 Go to previous messageGo to next message
Bob Rockefeller is currently offline Bob RockefellerFriend
Messages: 5
Registered: February 2017
Location: Midway, GA
Junior Member
Do you use WikiText? Does it handle Markdown?

The docs (http://help.eclipse.org/luna/index.jsp?topic=%2Forg.eclipse.mylyn.wikitext.help.ui%2Fhelp%2FMylyn+WikiText+User+Guide.html) show support for just Confluence, MediaWiki, Textile and TracWiki.
Re: Markdown support? [message #1754036 is a reply to message #1754028] Tue, 14 February 2017 05:16 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3793
Registered: July 2009
Senior Member

I expected that https://wiki.eclipse.org/Mylyn/FAQ#What_wiki_markup_languages_does_WikiText_support.3F was correct. Perhaps it is not. I had not installed it until earlier today, having the Winterwell editor installed already.

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Eclipse wont open
Next Topic:Eclipse installation on users/username/
Goto Forum:
  


Current Time: Sun Aug 09 18:50:26 GMT 2020

Powered by FUDForum. Page generated in 0.03403 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top