Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Eclipse Juno CDT Indexer Not working (C++14)
Eclipse Juno CDT Indexer Not working (C++14) [message #1752378] Mon, 23 January 2017 07:53 Go to next message
Sun Oo is currently offline Sun OoFriend
Messages: 2
Registered: January 2017
Junior Member
I try to use C++ 14 on Eclipse Juno with Cygwin gcc compiler.

It was properly build and I can execute it but it was showing me "std::thread" is not found. I suspect it was because Eclipse Juno is not properly indexing the C++ 14 so I change the setting to

C/C++ General > Preprocessor Include Paths,Marcros, etc > CDT GCC Built-in Compiler setting 
to

${COMMAND} -E -P -v -dD ${INPUTS} -std=c++14


but it still doesn't work. I have also post the source code below.

Could you please tell me what action I need to take to fix the problem?

[Main.cpp]

#include <iostream>
#include <thread>

void printSomething()
{
      std::cout << "Hello World";
}

int main()
{

   std::thread t(printSomething);

   std::cin.get();

   return 0;
}
Re: Eclipse Juno CDT Indexer Not working (C++14) [message #1752427 is a reply to message #1752378] Mon, 23 January 2017 16:56 Go to previous messageGo to next message
Marc-André Laperle is currently offline Marc-André LaperleFriend
Messages: 256
Registered: July 2009
Senior Member
Eclipse Juno is most likely too old for C++14. You you try the latest release? It's Neon.2. I was able to make it work with your code sample.
https://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/neon2

Also, if it doesn't work right away. Try to rebuild the index by right-click on the project > Index > Rebuild.
Re: Eclipse Juno CDT Indexer Not working (C++14) [message #1752452 is a reply to message #1752427] Tue, 24 January 2017 01:25 Go to previous message
Sun Oo is currently offline Sun OoFriend
Messages: 2
Registered: January 2017
Junior Member
Thank you Marc-Andre Laperle.

After changing to Neon.2 , it is working now.
Previous Topic:Unresolved inclusion: <Arduino.h>
Next Topic:Code Completion / Doxygen
Goto Forum:
  


Current Time: Wed May 18 07:47:29 GMT 2022

Powered by FUDForum. Page generated in 0.01934 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top