Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Failed to install TestNG through New Software Installation(Failed to install TestNG through New Software Installation)
icon1.gif  Failed to install TestNG through New Software Installation [message #1751990] Tue, 17 January 2017 14:55 Go to next message
Ambarish Sen is currently offline Ambarish SenFriend
Messages: 1
Registered: January 2017
Junior Member

While I am trying to install the TestNG plugin through Help- Install New Software, I am getting error, like below.

index.php/fa/28151/0/ PKIX path building failed: unable to find valid certification path to requested target

I tried in many ways to resolve this , like by firewall settings or proxy settings ,still not resolved. I am still getting the issue.

I understand this certificate failure issue. But not getting how to resolve. I am stuck and not able to use TestNG framework. Pleas guide.
  • Attachment: Capture.JPG
    (Size: 97.04KB, Downloaded 2376 times)
Re: Failed to install TestNG through New Software Installation [message #1752015 is a reply to message #1751990] Tue, 17 January 2017 19:56 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3953
Registered: July 2009
Senior Member

As the instructions on say, report back to them if you encounter any issues. You might also try going to the site, , yourself and downloading a zipped update site to install from as an Archive (adding it on the Available Software Sites preference page).

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Tue, 17 January 2017 19:58]

Report message to a moderator

Re: Failed to install TestNG through New Software Installation [message #1752027 is a reply to message #1752015] Wed, 18 January 2017 03:34 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31700
Registered: July 2009
Senior Member
I had some problems like this too (testing a whole bunch of update sites listed on the Eclipse Marketplace) and most of them went away when I installed the latest version of the JDK (which apparently has more root certificates in the certificate store). Otherwise you have to manually import the certificate into the store (which I figured out how to do by Googling that exception and finding information on stackoverflow).

Ed Merks
Professional Support:
Previous Topic:Eclipse neon launching error
Next Topic:https web service client : The service definition selected is invalid
Goto Forum:

Current Time: Sat Jan 16 01:21:22 GMT 2021

Powered by FUDForum. Page generated in 0.03283 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top