Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Trying to change the background colour of the editor drop down
Trying to change the background colour of the editor drop down [message #1750222] Mon, 19 December 2016 00:58 Go to next message
Troy Bronzan is currently offline Troy BronzanFriend
Messages: 1
Registered: December 2016
Junior Member
I'm using Eclipse in Linux and the drop down for the editor selector has a white background and white text. I'm trying to fix this because it's not very useful set up this way. Before running Eclipse I set export SWT_GTK3=0 because if I don't, all the buttons and whatnot have a lot of padding. Even if I don't do the export, I still get the same colour problem. I can't seem to find the correct setting under General -> Appearance -> Colors and Fonts. I've provided an image in case it's not clear as to what my issue is. Thanks in advance.

index.php/fa/27905/0/
Re: Trying to change the background colour of the editor drop down [message #1755309 is a reply to message #1750222] Thu, 02 March 2017 09:43 Go to previous messageGo to next message
Wolfgang Illmeyer is currently offline Wolfgang IllmeyerFriend
Messages: 2
Registered: March 2017
Junior Member
I have got the same problem. To me, it's appearance seems to be correlated to an update from Fedora 23 to 25 I recently performed. I would guess that somehow the Adwaita-gtk-2-theme might be the problem (updated from 3.18.0 to 3.22.2), but I haven't been able to find sufficient documentation for the somewhat convoluted gtkrc-2.0 format to try and fix it myself yet.

Have you been able to fix the problem meanwhile? Which OS and gtk2-theme do you use?
Re: Trying to change the background colour of the editor drop down [message #1755330 is a reply to message #1750222] Thu, 02 March 2017 11:31 Go to previous message
Wolfgang Illmeyer is currently offline Wolfgang IllmeyerFriend
Messages: 2
Registered: March 2017
Junior Member
I was able to fix that problem by adding this to my ~/.gtkrc-2.0

style "myspecialtooltip" {

  xthickness = 13
  ythickness = 13

  bg[NORMAL]   = "#eeeedd"
  fg[NORMAL]   = "#000000"
  bg[SELECTED] = "#eeeedd"

}
widget "gtk-tooltip*"                                              style "myspecialtooltip"
Previous Topic:AVD
Next Topic:genmodel
Goto Forum:
  


Current Time: Fri Aug 14 23:56:48 GMT 2020

Powered by FUDForum. Page generated in 0.02492 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top